A BEGINNER’S GUIDE TO PHOTOSHOP

Session 3: Masks – a deeper dive

Recap:

FLOW = **Bridge** > **Camera Raw** > **Photoshop**

- **Bridge**
  - Select image
- **Camera Raw**
  - Develop (Basic tab, Color Mixer tab)
  - Output settings
    - Profile, Bit Depth, Resize, Resolution (PPI)
    - Recommend applying Resize in Photoshop
  - Open (launches Photoshop)
- **Photoshop**
MASKS

• BASICS
  o Masks are a method used to define which areas of a layer are displayed as transparent and which areas are displayed as opaque (the default, without a mask, is fully opaque). Masks do not alter the pixel data in the associated layer, they just alter the transparency of “masked” areas.
  o A visual simile is that a layer with a mask will act like a clear sheet of acetate that has some areas covered in opaque paint
    ▪ The opaque areas “hide” what is below
    ▪ The transparent areas “reveal” what is below
  o The Layer Opacity sliders determine the transparency of all data on a layer, while a mask determines the transparency of one or more areas of the layer – leaving the rest opaque

• TYPES
  o Four mask types will be explored
    ▪ **Layer Mask, Vector Mask, Clipping Mask, and the special Layer Mask known as a Channel Mask**

  o **Layer Mask** is the most common
    ▪ Pixel-based (greyscale)
- Resolution-dependent (cannot be scaled)
- Edited with the *Painting Tools*, such as the Paint Brush, Paint Bucket, Eraser, and so forth.
- Indicated by a mask thumbnail, to the right of the layer thumbnail, that represents the grayscale channel that is painted to apply the masking.
- Transparency of areas on the masked layer is controlled by painting on the Layer Mask with *black*, *white*, and shades of *gray*.
  - Areas painted black become fully transparent, hiding data on the associated layer, revealing what is below.
  - Areas painted white are fully opaque, showing data on the associated layer, hiding what is below.
    - A mask filled with white leaves the data on the associated layer fully opaque, as if the layer had no mask.
  - Areas painted in shades of gray are semi-transparent, partially showing the data on the associated layer, partially revealing/hiding what is below.
    - The pixels on the associated layer are “mixed” with the pixels below, controlled by the shade of gray.
    - Dark gray results in more transparency, while light gray results in less...
transparency.

- **Vector Mask**
  - Functions like a *Layer Mask*
    - Shape-based (vector shapes and lines)
    - Resolution-independent (can be scaled)
    - Edited by drawing paths or shapes with the *Pen* or *Shape* tools
    - Indicated by a mask thumbnail, to the right of the layer thumbnail, that represents the grayscale channel that has paths and shapes drawn to apply the masking
    - Transparency of areas on the masked layer is controlled by drawing vector paths or shapes filled with *black*, *white*, and *shades of gray*.
      - As with a Layer Mask, black shapes or lines become fully transparent, hiding the data on the associated layer, and revealing what is underneath.
      - White shapes or lines are fully opaque, revealing the data on the associated layer, and hiding what is underneath.
      - Shapes or lines in shades of gray are semi-transparent, partially revealing or hiding what is underneath.
• Dark gray results in more transparency, while light gray results in less transparency.

• **Note:** A layer may have a Layer Mask and a Vector Mask simultaneously, or either mask type alone.

  o **Clipping Mask**

    • A *Clipping Mask* connects successive layers together (called a *Clipping Mask Stack*), creating a mask from the **content and transparency** of the bottommost layer (called the *Base Layer*).

    • The non-transparent areas of the Base Layer reveal the contents of the layers above it in the Clipping Mask Stack.

    • The transparent areas of the Base Layer hide the contents of the layers above it in the clipping mask stack.

    • Portions of the Base Layer that are semi-transparent will partially hide/reveal the content in the layers above it in the clipping mask stack.

    • A clipping mask can consist of multiple layers, but they must be successive layers.

    • The name of the Base Layer in the Clipping Mask Stack is underlined, and the thumbnails for the overlying layers in the Clipping Mask Stack are indented and display a clipping mask icon.
• **Channel Mask**
  - A *Channel Mask* is a Layer Mask, so all properties of a Layer Mask as described above apply. However, a Channel Mask is initially created by using data from an existing Alpha Channel, applying that data as a mask.
    - Existing Alpha Channels may include Saved Selections, Color Channels, etc.
    - After Channel data has been applied as a mask the new mask data can be refined using the *Painting Tools*, such as the Paint Brush, Paint Bucket, Eraser, and so forth.
    - **Note:** Creating a new mask with an *active selection* has the same results as creating a mask from a *Saved Selection Channel*.

• **WORKING WITH LAYER and/or VECTOR MASKS**
  - *Layer Masks* and *Vector Masks* can be added to an individual Layer or to a Layer Group.
  - If a layer has no mask, clicking the Add Layer Mask icon (in the Layers Panel) will add a *Layer Mask*.
    - **Note:** If a selection is active, the Layer Mask will be based on that selection.
  - Clicking the Add Layer Mask icon a second time will add a *Vector Mask*, resulting in both a Layer Mask and a Vector Mask applied to the layer.
- **Note:** If a path is selected, the Vector Mask will be based on the selected path.
  - If a *Shape* has been selected, go to the “Pick Tool Mode” drop-down and choose “Path” to convert it to a path. If “Shape” is chosen the new Vector Mask will not include the selected shape.
    - **Note:** To add a Vector Mask without first adding a Layer Mask, *Command -click* (Mac) or *Control -click* (Win) the Add Layer Mask icon.

- **ADDING A LAYER MASK TO THE ACTIVE LAYER**
  - You can add a Layer Mask that:
    - Initially *reveals all* image data on the associated layer
    - Initially *hides all* image data on the associated layer
    - Uses an *active selection* to initially *hide or reveal portions* of the image
    - Uses the *transparency* in the associated layer to initially *hide or reveal portions* of the image
  - With the layer to be masked active:
    - **Reveal All:** Click the *Add Layer Mask* button. This will create a mask filled with white (the default), leaving the associated layer fully opaque (reveal all)
      - An alternative is to choose *Layer > Layer Mask > Reveal All*.
    - **Hide All:** *Alt-click* (Win) or *Option-click* (Mac) the *Add Layer Mask* button. This will create a mask
filled with black, leaving the associated layer fully transparent (hide all)
  • An alternative is to choose Layer > Layer Mask > Hide All.

- **Reveal Selection:** Click the Add Layer Mask button while a *selection* is active. The selected areas will be filled with white, the unselected areas will be filled with black (reveal selection)
  • An alternative is to choose Layer > Layer Mask > Reveal Selection.

- **Hide Selection:** Alt-click (Win) or Option-click (Mac) the Add Layer Mask button while a *selection* is active. The selected areas will be filled with black, the unselected areas will be filled with white (hide selection)
  • An alternative is to choose Layer > Layer Mask > Hide Selection.

- **From Transparency:** From the Menu Bar at the top of the Photoshop application, choose Layer > Layer Mask > From Transparency. Photoshop creates a new mask with transparent areas of the image converted into opaque areas in the mask.

- **COPY or MOVE A MASK**
  o **Copy:** Alt-click (Win) or Option-click (Mac) on the mask to be copied, hold the mouse button down and drag the copied mask to the destination layer, then release.
    - If the destination layer already has a mask, Photoshop asks if you want to replace it with
copied mask. If “Yes” is selected the result is identical masks on both layers.

- **Move**: *Shift-click* on the mask to be moved, hold the mouse button down and drag the mask to the destination layer, then release.
  - If the destination layer already has a mask, Photoshop asks if you want to replace it with the moved mask. If “Yes” is selected the mask is removed from the original layer and applied to the destination layer.

**UNLINKING MASKS and LAYERS**

- By default, a layer or layer group is *linked* to its layer mask and/or vector mask, as indicated by the link icon ‡ between the thumbnails in the Layers panel.
- While linked, the layer and its masks move together in the image when you move either one with the Move tool ▲. Unlinking them lets them move independently, allowing the mask’s data and boundary to shift separately from the layer data and boundary.
- To unlink a layer from its mask, click the link icon ‡ between the two thumbnails.
- To reestablish the link between a layer and its mask, click between the layer and mask thumbnails. The link icon ‡ will reappear.

**DISABLE / ENABLE MASKS**

- Disabling a mask does not delete it, instead it temporarily turns the mask “off”. A red X appears over
the mask thumbnail in the Layers panel when the mask is disabled, and the contents of the layer are displayed as if the mask did not exist.

- To disable or enable a mask do one of the following:
  - Select the mask you want to disable or enable, and click the Disable/Enable Mask button in the Properties panel.
  - Shift-click the mask thumbnail in the Layers panel.
  - From the Menu Bar at the top of the Photoshop application, choose Layer > Layer Mask > Disable/Enable.

- APPLYING A MASK
  - You can apply a mask to permanently delete the hidden portions of a layer. Note that this is a destructive technique. The pixels that were hidden by the mask, and the mask itself, are deleted and no longer available for subsequent edits.
    - A non-destructive alternative is to Control-click (Mac) or Right-click (Win) the layer name in the Layers Panel and choose Covert to Smart Object. This will create an embedded "layer group" of the layer and its mask displaying only the visible pixels. To edit the mask in the future, simply open (double-click) the Smart Object layer.

- VIEW A MASK CHANNEL
  - In the Layers Panel a layer mask appears only as a thumbnail beside the associated image layer. However,
the data on a layer mask is also stored as a greyscale (Alpha) channel which can be viewed, either by itself (the greyscale data alone) or as a color overlay with the rest of the image data visible as well. In the Layers panel, do one of the following:

- **Alt-click** (Win) or **Option-click** (Mac) the layer mask thumbnail to view only the grayscale mask data. To redisplay the layers, **Alt-click** or **Option-click** the layer mask thumbnail. Alternatively, click the eye icon • in the Properties panel.
- Hold down **Alt+Shift** (Win) or **Option+Shift** (Mac), and click the layer mask thumbnail to view the mask data as a colored overlay on top of the image. Hold down **Alt+Shift** or **Option+Shift**, and click the thumbnail again to turn off the color display.

  • **Note:** Additional information regarding Alpha Channels (and Channel Masks) is provided in the accompanying document titled *Masks – Selections and Channels*.

**CHANGE MASK OVERLAY COLOR and/or OPACITY**

- When viewing mask data as a color overlay, it may be desirable to change the color and/or opacity of the overlay to make the mask data more easily visible against the colors in the image. *(Note: The overlay color and/or opacity has no effect on how masked areas are hidden or revealed.)*
  - Double-click the layer mask channel in the **Channels panel**.
To choose a new mask color: In the **Layer Mask Display Options** dialog box, click the color swatch and choose a new color.

To change the opacity: Enter a value between 0% and 100%.

Click OK.

**THE MASK PROPERTIES PANEL**
- When a Mask is active (selected) the Properties panel provides the means to control options that are specific to masks. The following options are available in the current version of Photoshop:
  - **Density:** The Density slider adjusts the mask opacity, reducing or increasing the application of the masked areas.
  - **Feather:** The Feather slider applies blurring to the mask edges, softening the edges of masked areas. Feathering is applied from the edges of the image inward, within the range of pixels you set with the slider.

- **Note:** The options available in the Mask Properties Panel are fully explored in the accompanying document titled **Masks.**

**CLIPPING MASKS**
- A **Clipping Mask** consists of two (or more) layers that are “connected” to each other in a **Clipping Mask Stack.**
- The content of the **bottom layer** (called the *Base Layer*) determines what is hidden or revealed in the layers above.
- If the base layer has some areas that are opaque and some areas that are transparent, a clipping mask will apply those values to the other layers in the clipping mask stack.
- The non-transparent parts of the base layer **reveal** the content of the layers above it in the clipping mask stack, while the transparent parts of the base layer **hide** the content of the layers above it in the clipping mask stack.
- A clipping mask can consist of multiple layers, but they must be successive layers.
- In the Layers Panel the name of the base layer in the clipping mask stack is underlined, and the thumbnails for the overlying layers are indented.
- The overlying layers display a clipping mask icon.

**Creating a Clipping Mask**

- Arrange the layers in the **Layers panel** with the intended clipping mask **base layer** at the bottom of the intended **clipping mask stack**, and with the layer(s) that you want to mask above. Then do one of the following:
  - In the Layers panel, hold down Alt (Win) or Option (Mac). Place the pointer over the line between the base layer and the first layer above it that you want to include in the clipping mask (the pointer changes to two overlapping circles ⊗) and click.
Alternative: In the Layers panel, select (make active) the first layer above the base layer and choose Layer > Create Clipping Mask.
- To add additional layers to the clipping mask, use either of the methods described above and work your way upward one level at a time in the Layers panel. Layers in the clipping mask stack are assigned the opacity and mode attributes of the base layer.
- If you create a new layer between layers already in a clipping mask stack, or drag an unclipped layer between layers in a clipping mask stack, the layer becomes part of the clipping mask.

- **Remove a layer from a clipping mask**
  To remove a layer from a clipping mask, do one of the following:
  - Hold down Alt (Win) or Option (Mac), position the pointer over the line separating two grouped layers in the Layers panel (the pointer changes to two overlapping circles ⌜), and click.
  - Alternative: In the Layers panel, select a layer in the clipping mask stack, and choose Layer > Release Clipping Mask. This command removes the selected layer, and any layers above it, from the clipping mask.

- **Release all layers in a clipping mask**
  - In the Layers panel, select the clipping mask layer just above the base layer and choose Layer > Release Clipping Mask. The clipping mask is removed, and the
layers return to normal.

• APPLY CHANNEL DATA AS A LAYER MASK
  o Method Number 1: Select and Apply Channel Data
    ▪ **Ctrl-click** (Win) / **Cmd-Click** (Mac) on a channel thumbnail to select and copy the channel data.
    ▪ With the layer to be masked active, click on the **Add New Layer Mask** icon in the **Layers panel**. This will create a Layer Mask consisting of the contents of the (selected) channel.
  o Method Number 2: Use **Apply Image**
    ▪ With the layer to be masked active (and no image data selected) click on the **Add New Layer Mask** icon in the **Layers panel**. This will create a blank (all white) mask. Click on this the new empty mask to make it active.
    ▪ From the **Menu Bar**, at the top of Photoshop's interface, choose **Image > Apply Image**.
    ▪ In the **Apply Image dialog box**, select (from the **Channel** dropdown) the **channel** you want apply as a Layer Mask.
    ▪ Set the **Blending Mode** to **Normal**.
    ▪ Click **OK**
  o **Note:** Both methods described above will produce the same results.
  o **Note:** Additional information regarding Alpha Channels and Channel Masks is provided in the accompanying document titled **Masks – Selections and Channels**.
Session 5 DOCS

- Layer Basics
- Layer Styles
- Layer Blend Modes
- Layer Blend Modes – Blend If
- Masks
- Masks – Selections and Channels
- Quick Mask Mode