Photoshop layers are like sheets of stacked acetate – opaque areas hide anything below while transparent areas reveal what is below.

**Masks** are a non-destructive and reversible way to make portions of a layer transparent. While the **Layer Opacity** slider adjusts the transparency of an entire Layer, a **Mask** can be used to adjust the transparency of one or more areas of a layer, leaving the rest opaque. A Mask can be edited at any time, providing the opportunity to further adjust the transparency of portions of the layer, if desired.
TYPES OF MASKS

This document will explore three Mask types: Layer Masks (the most common), Vector Masks, and Clipping Masks. (The PDF titled MASKS_SELECTIONS_CHANNELS explores Alpha Channel Masks, which are created and/or amended by using data from the Channels Panel.)

Layer Mask: A Layer Mask is pixel-based, resolution-dependent, and is edited with the Painting Tools, such as the Paint Brush, Paint Bucket, Eraser, and so forth. The Selection tools can also be used to create/edit a Layer Mask (more on this in the PDF titled MASKS_SELECTIONS_CHANNELS). A Layer Mask is indicated by a mask thumbnail, to the right of the layer thumbnail, that represents the grayscale channel that is painted to apply the masking.

The transparency of areas on the masked layer is controlled by painting on the Layer Mask with black, white, and shades of gray. Areas painted black become fully transparent, revealing what is underneath. Areas painted white are fully opaque, what is underneath. Areas painted in shades of gray are semi-transparent, partially revealing or hiding what is underneath. Dark gray results in more transparency, while light gray results in less transparency.

Layer Mask Example:

Two layers, with a single Layer Mask.

In the example above the Background layer (bottom of the layer stack) is an image of a group of red potatoes and a group of larger russet potatoes. Above the Background layer is a layer named Basket, with an image of a basket full of gold potatoes and a plastic description card. A Layer Mask has been added to the Basket layer. On the layer mask, the area with the basket full of gold potatoes is painted white, the description card is painted gray, and the rest of the mask is painted black. The result is the basket with gold potatoes is opaque (white in the mask), the description card is semi-transparent (gray in the mask), and the rest of the Basket layer is transparent (black in the mask) which reveals the russet and red potatoes from the Background layer.
Vector Mask: A Vector Mask, while functioning like a Layer Mask, is shape-based, resolution-independent, and is edited by drawing paths or shapes with the Pen or Shape tools. The Selection tools can also be used to create/edit a Vector Mask (more on this in the PDF titled MASKS_SELECTIONS_CHANNELS). A Vector Mask is indicated by a mask thumbnail, to the right of the layer thumbnail, that represents the grayscale channel that has paths and shapes drawn to apply the masking. A layer may have both a Layer Mask and a Vector Mask simultaneously, or either mask type alone.

The transparency of areas on the masked layer is controlled by drawing vector paths or shapes filled with black, white, and shades of gray. As with a Layer Mask, black shapes or lines become fully transparent, revealing what is underneath. White shapes or lines are fully opaque, hiding what is underneath. Shapes or lines in shades of gray are semi-transparent, partially revealing or hiding what is underneath. Dark gray results in more transparency, while light gray results in less transparency.

Vector Mask Example:

Three layers, one with a Vector Mask (middle) and one with a Layer Mask (top).

In the example above the Background layer (bottom of the layer stack) is a solid blue, “Layer 1” (middle of the layer stack) is a solid yellow, and “Layer 2” (top of the layer stack) is an image of a basket of gold potatoes.

“Layer 1” has a Vector Mask applied with some vector shapes added - a circle and some radiating elongated triangles – which are outlined in black and filled with white. The yellow of “Layer 1” remains visible where the shapes are white (white = opaque) and becomes invisible where the shapes are black (black = transparent), revealing the underlying blue of the Background layer.
“Layer 2” (top) has a **Layer Mask** applied with the area of the basket of potatoes painted white, and the rest of the mask painted black. “Layer 2” is at the top, so the area with the basket of potatoes remains visible (white = opaque) and the rest of the layer becomes invisible (black = transparent), revealing the yellow and blue shapes derived from “Layer 1” and the Background layer.

**Clipping Mask:** A *Clipping Mask* connects successive layers together (called a *Clipping Mask Stack*), creating a mask from the **content and transparency** of the bottommost layer (called the **Base Layer**). The non-transparent areas of the Base Layer reveal the contents of the layers above it in the Clipping Mask Stack. The transparent areas of the Base Layer hide the contents of the layers above it in the clipping mask stack. Portions of the Base Layer that are semi-transparent will partially hide/reveal the content in the layers above it in the clipping mask stack.

A clipping mask can consist of multiple layers, but they must be successive layers. The name of the Base Layer in the Clipping Mask Stack is underlined, and the thumbnails for the overlying layers in the Clipping Mask Stack are indented and display a clipping mask icon.

**Clipping Mask Example:**

A **Clipping Mask**, with a solid black shape in the **Base Layer** of the **Clipping Mask Stack**. Note that the base layer name (“Shape”) is underlined and the thumbnail for the layer above (“Photo”) is indented and displays the clipping mask icon (circled in red).
In the example above the Background layer (bottom of the layer stack) is a solid yellow, the layer named “Shape” (middle of the layer stack) is transparent except for a solid black shape, and the layer named “Photo” (top of the layer stack) is an image of a child. The top two layers (“Shape” and “Photo”) have been defined as a *Clipping Mask* with the layer named “Shape” as the *Base Layer*.

As described above, the non-transparent parts of the base layer reveal the content of the layer(s) above it in the clipping mask stack, while the transparent areas of the base layer hide the content of the layer(s) above it in the clipping mask stack. In the example above, the solid black shape on the base layer (“Shape”) reveals that portion of the “Photo” layer, while the transparent areas of the base layer hide the corresponding portion of the “Photo” layer. In addition, the transparent areas of the base layer (“Shape”) reveal the yellow of the Background layer.

**WORKING WITH MASKS**

**ADDING A LAYER or VECTOR MASK**

Layer Masks and Vector Masks can be added to an individual Layer or a Layer Group. When you add a Layer Mask or Vector Mask it can initially reveal all image data on the associated layer, hide all image data on the associated layer, or show/hide portions of the associated layer based on a selection or transparency. Painting on a Layer Mask, or drawing on a Vector Mask, precisely controls which portions of the associated layer are transparent (black = transparent) or which portions are opaque (white = opaque). In addition, the Properties panel provides options to change the opacity of the mask, invert the mask, refine the mask borders, and more.

If a layer has no mask, clicking the Add Layer Mask icon (circled below) will add a Layer Mask. Clicking the Add Layer Mask icon a second time will add a Vector Mask, resulting in both a Layer Mask and a Vector Mask applied to the layer. *Note:* To add a Vector Mask without first adding a Layer Mask, Command -click (Mac) | Control -click (Win) the Add Layer Mask icon. If a path or shape is selected, the Vector Mask will be based on the selected path or shape.

**Add a mask that initially reveals the entire layer or group**

- Click (make active) the Layer or Layer Group to be masked
- Click the Add Layer Mask button in the Layers panel

**Add a mask that initially hides the entire layer or group**

- Click (make active) the Layer or Layer Group to be masked
- Alt -click (Win) or Option -click (Mac) the Add New Layer Mask button in the Layers panel
• Alternative: From the Menu Bar at the top of the Photoshop application, choose Layer > Layer Mask > Hide All.

Add a mask that initially reveals a selected part of a layer
• Click (make active) the Layer or Layer Group to be masked
• With one or more areas of the layer selected (marching ants) click the Add New Layer Mask button in the Layers panel

• Alternative: From the Menu Bar at the top of the Photoshop application, choose Layer > Layer Mask > Reveal Selection.

Add a mask that initially hides a selected part of a layer
• Click (make active) the Layer or Layer Group to be masked
• With one or more image areas of the layer selected (marching ants) Alt-click (Win) or Option-click (Mac) the Add New Layer Mask button in the Layers panel

• Alternative: From the Menu Bar at the top of the Photoshop application, choose Layer > Layer Mask > Hide Selection.

Add a mask that initially hides transparent parts of a layer
• Click (make active) the Layer or Layer Group to be masked
• From the Menu Bar at the top of the Photoshop application, choose Layer > Layer Mask > From Transparency.

Photoshop creates a new mask with transparent areas converted into opaque areas in the mask. **Note:** The opaque color is typically black, but may vary, depending upon the filters and other processing previously applied to the layer.

Copy a mask from one layer to another layer
• Alt-click (Win) or Option-click (Mac) on the mask to be copied, hold the mouse button down and drag the copied mask to the destination layer, then release.

If the destination layer already has a mask Photoshop asks if you want to replace it with copied mask. If “Yes” is selected the result is identical masks on both layers.

Move a mask from one layer to another layer
• Shift-click on the mask to be moved, hold the mouse button down and drag the mask to the destination layer, then release.

If the destination layer already has a mask Photoshop asks if you want to replace it with
the moved mask. If “Yes” is selected the mask is removed from the source layer and applied to the destination layer.

UNLINKING MASKS and LAYERS
By default, a layer or layer group is linked to its layer mask and/or vector mask, as indicated by the link icon $ between the thumbnails in the Layers panel. While linked, the layer and its masks move together in the image when you move either one with the Move tool $$. Unlinking them lets them move independently, allowing the mask’s data and boundary to shift relative to the layer data.

- To unlink a layer from its mask, click the link icon $ between the two thumbnails.
- To reestablish the link between a layer and its mask, click between the layer and mask thumbnails. The link icon $ will reappear.

DISABLE / ENABLE MASKS
Disabling a mask does not delete it, instead it temporarily turns the mask “off”. A red X appears over the mask thumbnail in the Layers panel when the mask is disabled, and the contents of the layer are displayed as if the mask did not exist.

To disable or enable a mask do one of the following:

- Select the layer containing the mask you want to disable or enable, and click the Disable/Enable Mask button $ in the Properties panel.
- Shift-click the mask thumbnail in the Layers panel.
- From the Menu Bar at the top of the Photoshop application, choose Layer > Layer Mask > Disable/Enable.

APPLYING A MASK
You can apply a mask to permanently delete the hidden portions of a layer. Note that this is a destructive technique, meaning that it alters the pixels on the layer. The pixels that were hidden by the mask, and the mask itself, are deleted and no longer available for subsequent edits.

A non-destructive alternative is to Control-click (Mac) or Right-click (Win) the layer name in the Layers Panel and choose Covert to Smart Object. This will create an embedded "layer group" of the layer and its mask displaying only the visible pixels. To edit the mask in the future, simply open (double-click) the Smart Object layer.

VIEW A MASK CHANNEL
In the Layers Panel a layer mask appears only as a thumbnail beside the associated image layer. However, the data on a layer mask is also stored as a greyscale Alpha channel which can be viewed, either by itself (the greyscale data alone) or as a color overlay with the rest of the image data visible as well. In the Layers panel, do one of the following:
• *Alt-click* (Win) or *Option-click* (Mac) the layer mask thumbnail to view only the grayscale mask data. To redisplay the layers, *Alt-click or Option-click* the layer mask thumbnail. Alternatively, click the eye icon 🎧 in the Properties panel.

• Hold down *Alt+Shift* (Win) or *Option+Shift* (Mac), and click the layer mask thumbnail to view the mask data as a colored overlay on top of the image. Hold down *Alt+Shift or Option+Shift*, and click the thumbnail again to turn off the color display.

  *Note:* The PDF titled *MASKS_SELECTIONS_CHANNELS* provides additional information regarding Alpha Channels and Channel Masks.

**CHANGE MASK OVERLAY COLOR and/or OPACITY**

When viewing mask data as a color overlay, it may be desirable to change the color and/or opacity of the overlay to make the mask data more easily visible against the colors in the image. *(Note: Changing the overlay color and/or overlay opacity has no effect on how masked areas are hidden or revealed.)*

1. Double-click the layer mask channel in the **Channels panel**.
2. To choose a new mask color: In the **Layer Mask Display Options** dialog box, click the color swatch and choose a new color.
3. To change the opacity: Enter a value between 0% and 100%.
4. Click OK.

**THE MASK PROPERTIES PANEL**

When a Mask is active (selected) the Properties panel provides the means to control options that are specific to masks. The following options are available in the current version of Photoshop:

**Density:**
Drag the Density slider to adjust the mask opacity. At 100% density, the mask is opaque and blocks out any underlying area of the layer. As you lower the density, the mask becomes increasingly transparent, revealing data on layers below.

**Feather:**
Drag the Feather slider to apply feathering to the mask edges. Feathering applies a blur to the edges of the mask data, creating a softer transition between the masked and unmasked areas.

**Refine:**
**Select and Mask** *(As the section name implies, these tools can be used on Mask data or on a Selection.)*
The **Select and Mask** section provides tools to fine tune the data in a mask (or selection) and to adjust how mask (or selection) data is displayed.
**View Mode settings**
Choose one of the following view modes from the View drop-down menu:

- **Onion Skin (O)**: Displays Masked (or selected) areas with an animation-style onion skin scheme.
- **Marching Ants (M)**: Displays mask (or selection) borders as marching ants.
- **Overlay (V)**: Masked (or selected) areas are displayed as a semi-transparent color overlay. The default color is red.
- **On Black (A)**: Masked (or selected) areas are displayed as a semi-transparent black overlay.
- **On White (T)**: Masked (or selected) areas are displayed as a semi-transparent white overlay.
- **Black & White (K)**: Masked (or selected) areas are displayed as black and white.
- **On Layers (Y)**: Masked (or selected) areas are displayed as transparent, revealing underlying layer data.

*Note*: Press F to cycle through the view modes and X to temporarily disable all modes.

**Show Edge**: Shows the area of mask (or selection) refinement.

**Show Original**: Shows the original mask (or selection).

**High Quality Preview**: Renders an accurate preview of the changes. This option may affect performance. When this option is selected, while working on the image, hold down the left mouse button (mouse down) to view a higher-resolution preview. When this option is deselected, a lower-resolution preview is displayed even on mouse down.

**Transparency/Opacity**: Sets transparency/opacity for the View Mode.

**Refine modes**
Sets the edge refinement method used by Edge Detection, Refine Hair, and the Refine Edge Brush Tool.

- **Color Aware**: Choose this mode for simple or contrasting backgrounds.
- **Object Aware**: Choose this mode for hair or fur on complex backgrounds.

**Edge Detection settings**

**Radius**: Determines the size of the selection border in which edge refinement occurs. Use a small radius for sharp edges, and a large one for softer edges.
**Smart Radius**: Allows for a variable width refinement area around the edge of your selection. Among other use cases, this option is helpful if your selection is a portrait that includes both hair and shoulders. In such portraits, the hair might require a larger refinement area than the shoulders, where the edge is more consistent.

**Global Refinement settings**

**Smooth**: Reduces irregular areas (“hills and valleys”) in the selection border to create a smoother outline

**Feather**: Blurs the transition between the selection and the surrounding pixels

**Contrast**: When increased, soft-edged transitions along the selection border become more abrupt. Typically, the Smart Radius option and refinement tools are more effective.

**Shift Edge**: Moves soft-edged borders inward with negative values or outward with positive ones. Shifting these borders inward can help remove unwanted background colors from selection edges.

**Output Settings**

**Decontaminate Colors**: Replaces color fringes with the color of fully selected pixels nearby. The strength of color replacement is proportionate to the softness of selection edges. Adjust the slider to change the decontamination amount. 100% (maximum strength) is the default value. *Because this option changes pixel color, it requires output to a new layer or document. Retain the original layer so you can revert to it if needed.*

**Output To**: Determines whether the refined selection becomes a selection or mask on the current layer, or produces a new layer or document.
Notes:

- Click (Reset the Workspace) to revert all settings to the original state (the settings in place when you entered the Select and Mask workspace). This option also reverts to the original selections/masks applied to the image when you entered the Select and Mask workspace.
- Select Remember Settings to save the settings for use with future images. The settings are applied afresh to all future images, including the current image if it is reopened in the Select and Mask workspace.

ABOUT CLIPPING MASKS

A Clipping Mask consists of two (or more) layers that are “connected” to each other in a Clipping Mask Stack. The content of the bottom layer (called the Base Layer) determines what is hidden or revealed in the layers above. If the base layer has some areas that are opaque and some areas that are transparent, a clipping mask will apply those values to the other layers in the clipping mask stack. The non-transparent parts of the base layer reveal the content of the layers above it in the clipping mask stack, while the transparent parts of the base layer hide the content of the layers above it in the clipping mask stack.

A clipping mask can consist of multiple layers, but they must be successive layers. In the Layers Panel the name of the base layer in the clipping mask stack is underlined, and the thumbnails for the overlying layers are indented. The overlying layers display a clipping mask icon.

CREATING A CLIPPING MASK

Arrange the layers in the Layers panel with the intended clipping mask base layer at the bottom of the intended clipping mask stack, and with the layer(s) that you want to mask above. Then do one of the following:

- In the Layers panel, hold down Alt (Win) or Option (Mac). Place the pointer over the line between the base layer and the first layer above it that you want to include in the clipping mask (the pointer changes to two overlapping circles 🔄) and click.
- In the Layers panel, select (make active) the first layer above the base layer and choose Layer > Create Clipping Mask.

To add additional layers to the clipping mask, use either of the methods described above and work your way upward one level at a time in the Layers panel. Layers in the clipping mask stack are assigned the opacity and mode attributes of the base layer.

If you create a new layer between layers already in a clipping mask stack, or drag an unclipped layer between layers in a clipping mask stack, the layer becomes part of the clipping mask.

Remove a layer from a clipping mask

To remove a layer from a clipping mask, do one of the following:
• Hold down Alt (Win) or Option (Mac), position the pointer over the line separating two grouped layers in the Layers panel (the pointer changes to two overlapping circles), and click.

• In the Layers panel, select a layer in the clipping mask stack, and choose Layer > Release Clipping Mask. This command removes the selected layer, and any layers above it, from the clipping mask.

**Release all layers in a clipping mask**

In the Layers panel, select the clipping mask layer just above the base layer and choose Layer > Release Clipping Mask. The clipping mask is removed, and the layers return to normal.

**Clipping Mask Example:**

The example below illustrates how a Clipping Mask works. In this example, the goal is to reveal the wood grain from the layer named “Wood” only where the text in the layer named “Text” exists, hiding the wood grain everywhere else. The example starts with an image of wood grain in one layer (“Wood”) and above that a text layer (“Text”).

**Note:** The color of the text on layer “Text” is irrelevant (shown white in this example). It is the opacity of the data on the base layer that controls how and where the image data above is revealed. In this example the text characters can be any color - the results will be the same.

![Clipping Mask Example Image](image_url)

Starting point: “Text” layer added above “Wood” layer

If the “Text” layer is to control where the wood grain is revealed it is necessary to make the “Text” layer the base layer of the clipping mask stack. Move the “Text” layer below the “Wood” layer. Then, with the “Wood” layer active (selected), open the **Layers Menu** and select **Create**
**Clipping Mask.** Now the wood grain is revealed only where the text layer is opaque (the word “Text”). Note that the name of the base layer (“Text”) is now underlined and the thumbnail for the masked layer (“Wood”) is indented and displays the clipping mask icon.

Wood grain revealed where the base layer (“Text”) is opaque

There are many additional adjustments that can be made (the options are nearly endless). For example, the “Wood” layer can be moved, adjusting the position of the revealed grain relative to the stationary “Text”. Also, *Layer Effects* can be applied to the base layer, effecting the way the grain is revealed. The example below shows what happens if an *Inner Shadow* effect is applied to the “text” layer.
Inner Shadow effect applied to the base layer ("Text") changes how the wood grain is displayed

**Use a Clipping Mask to Control How Adjustment Layers Are Applied:**
Adjustment layers, by default, result in adjustments to the data visible from all layers below the adjustment layer. A clipping mask can be applied to restrict the results of an *Adjustment Layer* to only the layer directly below it.

When an Adjustment Layer is created (*Hue/Saturation* in the example below) the Properties Panel displays the appropriate adjustment controls and, at the bottom, a row of option buttons. The button at the left, the *clipping control* button (circled), determines whether the adjustments are clipped (restricted) to the layer immediately below. (Adjustment layers, by default, result in adjustments to the data visible from all layers below the adjustment layer.)

Selecting that option creates a clipping mask stack with the layer directly below ("Shell" in this example) assigned as the base layer. Base layer opacity determines how/where the adjustment is applied. If there are no transparent areas in the base layer the adjustments will not “pass through” to the layers below. Instead, the adjustments will be restricted to the base layer only.
A Clipping Mask restricts Adjustment Layer results to the layer directly below (the base layer).

As with any clipping mask, the name of the base layer (“Shell”) is now underlined and the thumbnail for the masked layer (“Hue/Saturation”) is indented and displays the clipping mask icon.