PHOTOSHOP LAYER BASICS

Photoshop layers are like sheets of stacked acetate – opaque areas cover anything below while transparent areas reveal what is below. A layer can be moved to position the contents relative to the contents of another layer below (or above), like sliding a sheet of acetate in a stack, and the opacity of a layer can be adjusted to increase or decrease content transparency.

A new image begins as a single layer, called the **Background** layer. Additional layers can be added to an image, limited only by your computer’s memory. These additional layers are used to perform tasks such as compositing multiple images, adding text to an image, and so forth.

A **Layer Style** can be added to create a special effect such as a drop shadow or a glow. A **Layer Mask** can be used to hide/reveal specific areas. A **Blending Mode** can be applied to alter the way the contents of two or more layers interact. **Adjustment Layers** can be applied, which consist of instructions that Photoshop uses to make color, tonal, and other adjustments that affect how the
pixels in the layers below are displayed, while leaving those pixels unchanged. This is called **Non-Destructive Editing**.

A special type of layer, called a **Smart Object**, can be transformed (scaled, skewed, or reshaped) without changing the image pixels. In addition, a **Smart Object** can be edited as a separate image, even after placing it in a Photoshop image. **Smart Objects** can also have **Smart Filter Effects** applied, non-destructively, that can later be tweaked or removed.

**Layers Panel Overview**

The **Layers Panel** can be accessed from the **Menu Bar** at the top of the Photoshop application - choose **Window > Layers**.

Access the Layers Panel from Photoshop’s Menu Bar.
The Layers Panel lists all of the Layers, Layer Groups, and Layer Effects used in an image, and provides the tools used to arrange Layers in a logical order, combine Layers into Groups, apply attributes and masks, make Layers visible or invisible, and much more.

Photoshop Layers Panel

The Layers Panel Menu contains a wide range of commands and options pertaining to Layers. To open the Layers Panel menu, click the icon (four lines) in the upper-right corner of the panel.

The Layer Filtering Menu is used to display a subset of the layers in an image, based on Kind, Name, Effect, Mode, Attribute, Color, Smart Object, Selected, and Artboard. The Filter icons to the right of the menu can be used to filter by (left to right) Pixel Layers, Adjustment Layers, Type Layers (Text Layers), Shape Layers, and Smart Objects. The Switch Icon is used to turn Layer Filtering Off and On.
Layer Filtering Menu - *Kind* is chosen and *Pixel Layers* are selected in this example.

The options in the **Blend Mode Menu** can be used to change the way that pixels on the active layer interact with pixels on layers underneath it.

Adjusting the **Layer Opacity** slider determines the transparency of the layer: 0 = fully transparent, 100 = fully opaque. Adjusting this slider affects both pixels and effects.

Adjusting the **Fill Opacity** slider adjusts the amount of opacity of the pixels only - any layer styles and effects remain 100% opaque.

Clicking (toggles On and Off) one or more of the **Lock Options** controls what can be edited for the layer. A padlock icon indicates that something in the layer is currently locked. The items that can be locked/unlocked are (left to right):
- **Transparent Pixels** (cannot paint where it is transparent)
- **Image Pixels** (cannot alter pixels on the layer)
- **Position** (cannot move items in the layer)
- **Artboards and Frames** (cannot auto-nest)
- **Lock All** (layer is totally protected from any editing).

A **Layer Group** can contain multiple individual Layers and can also have other **Layer Groups** nested (sub-groups). Each layer in a group can have the visibility and opacity adjusted. Each can also have an adjustment layer, mask, and so forth, applied. Layer Groups can also have the group visibility and opacity adjusted, and have a mask, adjustment layers, and so forth, applied - which will affect all of the layers in the group.

The **fx** icon indicates that a **Layer Style** with one or more **Effect** has been applied to the Layer. These are non-destructive special effects such as drop shadow, glow, color overlay, and so forth. Each effect will be listed and each can be tweaked or removed. Clicking on the arrow to the right of the **fx** icon toggles the list of effects On and Off. Double clicking on the **fx** icon opens the **Layer Style options menu**.

Double clicking on a **Layer Thumbnail** opens the **Layer Style options menu**.

Clicking the **Eye Icon** next to a layer toggles the layer Visibility On and Off. If the eye is showing the layer is visible.
The **Layer Control Icons** at the bottom of the Layers Panel are (left to right):

- **Link Layers** (links selected layers so they move together as a unit)
- **Add Layer Style** (opens the *Layer Style* options menu)
- **Add Layer Mask** (creates a *Layer Mask* for the active layer)
- **New Adjustment Layer** (inserts a new *Adjustment Layer* above the active layer)
- **Create New Layer Group** (inserts a new empty *Layer Group* above the active layer)
- **Create New Layer** (inserts a new empty *Layer* above the active layer)
- **Delete Layer** (deletes the currently active layer)

**Layers Panel Options**

To access the Layers Panel options, open the Layers Panel Menu and select Panel Options:

1. Click this menu
2. Select Panel Options...

Select the preferred **Thumbnail Size**: choose *Small*, *Medium*, or *Large*. Select **None** to turn thumbnails *Off*.

Select the preferred **Thumbnail Contents**: choose *Entire Document* to display the contents of the entire document, or select *Layer Bounds* to restrict the thumbnail to the pixels on the layer.
There are three Check Box options at the bottom. Selecting an option turns that option On (check mark), un-selecting an option turns the option Off (no check mark).

*Use Default Masks on Fill Layers* (If checked, automatically adds a Layer Mask to a new Fill Layer or Adjustment Layer. If un-checked, Layer Masks must be added manually.)

*Expand New Effects* (If checked, the list of all effects applied to a layer is expanded by default. If un-checked, the effects list defaults to collapsed.)

*Add “copy” to Copied Layers and Groups* (If checked, the word “copy” is appended to the name of a copied Layer or Layer Group. If un-checked, the name of a copied Layer or Layer Group is the same as the original.)

**Layer Types**

Layers are represented by a Layer Icon (thumbnail) that indicates the Layer Type:

- **Layer Group:** Represented by a “Folder” Icon. To expand or collapse Layer Groups click the triangle to the left of a group folder.
- **Type Layer:** Represented by a thumbnail with the Letter “T”. A Type Layer contains type (text) that can be edited to change the words, character size, character color, fonts, etc.
- **Adjustment Layer:** Represented by an Adjustment Thumbnail that indicates the kind of adjustment being applied.
- **Layer Style:** Represented by an “Eye” Icon followed by the Effect Family and the Effect Name.
**Layer Mask:** Represented by a **Mask Thumbnail**, next to the **Primary Layer Thumbnail**, showing masked areas in black and unmasked areas in white.

**Smart Object:** Represented by a **Smart Object Icon** in the lower right corner of the **Standard Image Thumbnail**.

**Art Layer:** Represented by a **Standard Image Thumbnail**. These are regular image pixel layers.

**Background:** Represented by a **Standard Image Thumbnail** followed by the word “**Background**”. This layer is always locked (indicated by the **Padlock Icon** on the right) and cannot be moved or have layer effects applied to it.

---

**Convert the Background Layer into a Regular Layer:**
The bottommost Layer displayed in the Layers panel is a special layer called **Background**. This is the default layer for any new image, and is the starting point for all subsequent edits. An image can have only one Background Layer. The Background Layer cannot include any transparent pixels. You cannot change the stacking order of a Background Layer, its blending mode, or its opacity. However, you can convert a Background Layer into a Regular Layer, and then change any of these attributes:

- **Double-click** the **Background Layer Thumbnail** in the **Layers panel**, or choose **Layer > New > Layer From Background**. The Background Layer is converted to a Regular Layer with the default name “Layer 0”.

**Convert a Regular Layer into a Background Layer:**
Select a Regular Layer in the **Layers panel**. From the **Menu Bar** at the top of the Photoshop application, choose **Layer > New > Background From Layer**. The layer becomes the Background and any **transparent** pixels in the layer are converted to the current background color, and the layer drops to the bottom of the layer stack.

**Duplicate a Regular Photoshop Layer or Group within an image:**
Select a **Layer or Group** in the **Layers panel**, then **drag** the Layer or Group to the **Create a New Layer** button  at the bottom of the **Layers panel**. Alternatively: Choose **Duplicate Layer** or **Duplicate Group** from the **Layers menu** or the **Layers panel** menu. Enter a name for the layer or group, and click **OK**.

**Duplicate a Regular Photoshop Layer or Group in another image:**
Open both the source and destination images. From the **Layers panel** of the source image, select one or more **Layers or Layer Groups**. Do one of the following:

1. **Drag** the layer or group from the Layers panel to the destination image.

2. Select the **Move tool**, and **drag** from the source image to the destination image. The duplicate layer or group appears above the active layer in the **Layers panel** of the destination image. **Shift-drag** to move the image content to the same location it occupied in the source image (if the source and destination images have the same pixel dimensions) or to the center of the document window (if the source and destination images have different pixel dimensions).
3. Choose **Duplicate Layer** or **Duplicate Group** from the *Layers menu* or the *Layers panel menu*. Choose the destination document from the Document pop-up menu, and click **OK**.

4. Choose **Select > All** to select all the pixels on the layer, and choose **Edit > Copy**. Then choose **Edit > Paste** in the destination image. (This method copies only pixels, excluding layer properties such as blending mode.)

*Create a new document from a Photoshop Layer or Group:*  
Select a *Layer* or *Group* from the *Layers panel*. Choose **Duplicate Layer** or **Duplicate Group** from the *Layers menu* or the *Layers panel menu*. Choose **New** from the Document pop-up menu, and click **OK**.

**Useful Tips and Shortcuts**

- **Click** on a *Layer Thumbnail* to select the layer (also becomes the active layer)
- **Cmd/Ctrl+click** to select multiple layers
- **Click** the *Eye Icon* to turn the visibility *On* or *Off* (toggle)
- **Drag** your curser through sequential *Eye Icons* to turn the visibility *On* or *Off* on multiple layers
- **Cmd/Ctrl+J** to copy a layer
- **Click** the *Padlock Icon* on the Background Layer to convert it to a regular layer
- **Cmd/Ctrl+G** to move all selected layers into a new group
- **Cmd+Option+Shift+E (Ctrl+Alt+Shift+E windows)** to create a new merged layer above all the other layers
- **Hold Option/Alt** while adding a mask to create an inverted layer mask (filled with black)
- **Drag** elements from a document *Layers panel* into other documents, then release
- **Drag** the “fx” icon (or the word *Effects*) to the trashcan, then release, to delete a *Layer Effect*
- **Drag** the name of a *Layer Effect* (*Stroke*, *Drop Shadow* etc.) to the trash to delete an individual effect
- **Drag** the “fx” icon (or the word *Effects*) and release over another Layer to duplicate the Layer Effect