
Creating A Personal Website 

Using Adobe Dreamweaver 
 

DREAMWEAVER PREFERENCES 

 
Set GENERAL preferences 

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh). 

2. Choose General from the Category list on the left, then set any of the following options: 

Note: After changing any Dreamweaver Preferences settings you must select 
Apply to save the new settings. Closing the dialog without selecting Apply will 
revert back the settings in place when the dialog was opened. 

Open Documents In Tabs (Macintosh only) 
Opens all documents in a single window with tabs that let you switch between 
documents.  

Note: On Windows this is the default, each file opened will have a tab at the top 
of the Document Window. Selecting a tab displays the associated document. 

Show Start Screen 
Displays the Dreamweaver Welcome screen when you start Dreamweaver or when you 
do not have any documents open. 

Reopen Documents on Startup 
Opens any documents that were open when you closed Dreamweaver. If this option is 
not selected, Dreamweaver displays the Welcome screen or a blank screen when you 
start (depending on your Show Welcome Screen setting). 

Warn When Opening Read-Only Files 
Alerts you when you open a read-only (locked) file. Choose to unlock/check out the file, 
view the file, or cancel. 

Enable Related Files 
Displays files that are connected to the current document (for example, CSS or 
JavaScript files). Dreamweaver displays a button for each related file at the top of the 
document, and opens the file if you click the button. 
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Discover Dynamically-Related Files 
Allows you to select whether Dynamically-Related Files appear in the Related Files 
toolbar automatically, or after manual interaction. You can also choose to disable the 
discovery of Dynamically-Related Files. Note: Dynamically-Related Files are files that are 
referenced in a related file (PHP, for example), but are not called directly in the page 
HTML. 

Update Links When Moving Files 
Determines what happens when you move, rename, or delete a document within your 
site. Set this preference to always update links automatically, never update links, or 
prompt you to perform an update.   

Show Dialog When Inserting Objects 
Determines whether Dreamweaver prompts you to enter additional information when 
inserting images, tables, Shockwave movies, and certain other objects by using the 
Insert panel or the Insert menu. If this option is off, the dialog box does not appear and 
you must use the Property inspector to specify the source file for images, the number of 
rows in a table, and so on. For roll over images and Fireworks HTML, a dialog box always 
appears when you insert the object, regardless of this option setting. (To temporarily 
override this setting, Control-click (Windows) or Command-click (Macintosh) when 
creating and inserting objects.) 

Enable Double-Byte Inline Input 
Allows you to enter double-byte text directly into the Document window if you are using 
a development environment or language kit that facilitates double-byte text (such as 
Japanese characters). When this option is deselected, a text input window appears for 
entering and converting double-byte text; the text appears in the Document window 
after it is accepted. 

Switch To Plain Paragraph After Heading 
Specifies that pressing Enter (Windows) or Return (Macintosh) at the end of a heading 
paragraph in Design or Live view creates a new paragraph tagged with a <p> tag. (A 
heading paragraph is one that is tagged with a heading tag such as <h1> or <h2>.) When 
the option is disabled, pressing Enter or Return at the end of a heading paragraph 
creates a new paragraph tagged with the same heading tag (allowing you to type 
multiple headings in a row and then go back and fill in details). 
 

Allow Multiple Consecutive Spaces 
Specifies that typing two or more spaces in Design or Live view creates nonbreaking 
spaces that appear in a browser as multiple spaces. (For example, you can type two 
spaces between sentences, as you would on a typewriter.) This option is designed 
mostly for people who are used to typing in word processors. When the option is 
disabled, multiple spaces are treated as a single space (because browsers treat multiple 
spaces as single spaces). 

Use <strong> and <em> in Place of <b> and <i> 
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Specifies that Dreamweaver applies the <strong> tag whenever you perform an action 
that would normally apply the <b> tag, and applies the <em> tag whenever you perform 
an action that would normally apply the <i> tag. Such actions include clicking the Bold or 
Italic buttons in the text Property inspector in HTML mode and choosing Format > 
Style > Bold or Format > Style > Italic. To use the <b> and <i> tags in your documents, 
deselect this option. 

Note: The World Wide Web Consortium discourages use of the <b> and <i> tags; 
the <strong> and <em> tags provide more semantic information. However, if the 
tags are used solely for display formatting purposes (bold text and/or italic text), 
and are not intended to impart special semantic information (importance or 
emphasis), then <b> and <i> are preferred (<b> stands for Bold Text, <i> stands 
for Italic Text). 

Warn when placing editable regions within <p> or <h1> - <h6> tags 
Specifies whether a warning message is displayed whenever you save a Dreamweaver 
template that has an editable region within a paragraph <p> or heading <h1, h2, …> tag. 
The message tells you that users will not be able to create more paragraphs in the 
region. It is enabled by default. 

Maximum Number of History Steps 
Sets the number of steps that the History panel retains and shows. (The default value 
should be sufficient for most users.) If you exceed the given number of steps in the 
History panel, the oldest steps are discarded. 

Spelling Dictionary 
lists the available spelling dictionaries. If a dictionary contains multiple dialects or 
spelling conventions (such as American English and British English), the dialects are 
listed separately in the Dictionary pop-up menu. 

 
 

Set ACCESSIBILITY preferences 
Accessibility refers to making your web site accessible to users with disabilities. When you 
create accessible pages, you need to associate information, such as labels and descriptions, 
with your page objects to make your content accessible to all users. 

To do this, activate the Accessibility dialog box for each object, so that Dreamweaver prompts 
you for accessibility information when you insert objects. You can activate a dialog box for any 
of the objects in the Accessibility category in Preferences. 

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh). 
 

2. Select Accessibility from the Category list on the left, select an object, set any of the 
following options, and click Apply. 
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Show Attributes When Inserting 
Select the objects for which you want to activate accessibility dialog boxes. For example, form 
objects, frames, media, and images. 

Keep Focus In The Panel 
Maintains focus on the panel, which makes it accessible to the screen reader. (If you do not 
select this option, the focus remains in Design or Code view when a user opens a panel.) 

Offscreen Rendering 
Select this option when using a screen reader. 

Note: Accessibility attributes appear in the Insert Table dialog box when you insert a 
new table. 
 
 

Set COFE FORMAT preferences 
You can change the look of your code (as displayed in Code View) by specifying formatting 
preferences such as indentation, line length, and the case of tag and attribute names. 

All the Code Format options, except the Override Case Of option, are automatically applied only 
to new documents or additions to documents that you subsequently create. 

To reformat existing HTML documents, open the document, and select Edit > Code > Apply 
Source Formatting. 

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh). 

2. Choose Code Format, the set any of the following options: 

Indent 
Indicates whether code generated by Dreamweaver should be indented (according to 
the indentation rules specified in these preferences) or not. 

Note: Most of the indentation options in this dialog box apply only to code 
generated by Dreamweaver, not to code that you type. To make each new line of 
code that you type indent to the same level as the previous line, select View > 
Code View Options > Auto-Indent option.  

With 
(Text box and drop-down menu) Specifies how many spaces or tabs Dreamweaver 
should use to indent code that it generates. For example, if you type 3 in the box and 
select Tabs in the pop-up menu, then code generated by Dreamweaver is indented 
using 3 tab characters for every level of indentation. 

Tab Size 
Determines how many characters wide each tab character appears in Code view. For 
example, if Tab Size is set to 4, then each tab is displayed in Code view as a four-
character-wide blank space. If, additionally, Indent With is set to 3 Tabs, then code 
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generated by Dreamweaver is indented using 3 tab characters for every level of 
indentation, which appears in Code view as a twelve-character-wide blank space. 

Note: Dreamweaver indents using either spaces or tabs; it does not convert a 
run of spaces to a tab when inserting code. 

Emmet 
Select this option if you plan to use Emmet abbreviations as you code. Selecting this 
option ensures that when you press Tab, Dreamweaver converts the Emmet 
abbreviation into full HTML or CSS code. 

Line Break Type 
Specifies the type of remote server (Windows, Macintosh, or UNIX) that hosts your 
remote site. Choosing the correct type of line break characters ensures that your HTML 
source code appears correctly when viewed on the remote server. This setting is also 
useful when you are working with an external text editor that recognizes only certain 
kinds of line breaks. For example, use CR LF (Windows) if Notepad is your external 
editor, and use CR (Macintosh) if SimpleText is your external editor. 

Note: For servers that you connect to using FTP, this option applies only to 
binary transfer mode; the ASCII transfer mode in Dreamweaver ignores this 
option. If you download files using ASCII mode, Dreamweaver sets line breaks 
based on the operating system of your computer; if you upload files using ASCII 
mode, the line breaks are all set to CR LF. 

TD Tag: Do Not Include A Break Inside The TD Tag 
Addresses a rendering problem that occurs in some older browsers when white space or 
line breaks exist immediately after a <td> tag, or immediately before a </td> tag. When 
you select this option, Dreamweaver does not write line breaks after a <td> or before a 
</td> tag, even if the formatting in the Tag Library indicates that the line break should 
be there. 

Advanced Formatting 
Allows you to set formatting options for individual tags and attributes in the Tag Library 
Editor. 

White Space Character 
(Japanese version only) Lets you select either &nbsp; or Zenkaku space for HTML code. 
The white space selected in this option will be used for empty tags when creating a table 
and when the “Allow Multiple Consecutive Spaces” option is enabled in Japanese 
Encoding pages. 

Minimum code folding size 
The default code folding size is two lines. With this default setting, all code fragments 
that have at least two lines of code are collapsible. Code fragments that are lesser than 
two lines can be collapsed only by selecting the code. 
 



Page 5 of 20 
 

Set CODE HINTS preferences 
Use the code hint preferences to configure how you want code hints to work.  

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh). 

2. Select Code Hints from the category on the left. Set any of the following options: 

Close tags 
Specify how you want Dreamweaver to close tags. 

o After typing "</" -  

o After typing the open tag's ">" - Select this option if you want Dreamweaver to 
automatically add a closing tag after you close the opening tag. 

o Never - Set this option if you don't want Dreamweaver to automatically add 
closing tags. 

Enable code hints 
Select this option to enable or disable code hinting and code completion in 
Dreamweaver.  

Enable description tooltips 
Select this option to enable descriptions to appear with your code hints. These 
descriptions provide additional information about the code you are writing. 

Auto-insert braces  
When checked, a closing brace is automatically inserted whenever user types an 
opening brace. When unchecked, a closing brace is not inserted when user types 
opening brace. Applies to all types of braces and all file types (html, php, css, js). 

Auto-insert quotes  
When checked, a closing quote Is automatically inserted whenever user types an 
opening quote. When unchecked, a closing quote is not inserted when user types 
opening quote. Applies to both single and double quotes and all file types (html, php, 
css, js). 

 
Set CODE REWRITING preferences 
Use the code rewriting preferences to specify how and whether Dreamweaver modifies your 
code while opening documents, when copying and pasting form elements, and when entering 
attribute values and URLs using tools such as the Property inspector. These preferences have no 
effect when you manually edit HTML or scripts in Code view. 

If you disable the rewriting options, invalid-markup items are displayed in the Document 
window for HTML that it would have been rewritten. 

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh). 

2. Select Code Rewriting from the Category list on the left. Set any of the following 
options: 
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Fix Invalidly Nested and Unclosed Tags 
Rewrites overlapping tags. For example, <b><i>text</b></i> is rewritten 
as <b><i>text</i></b>. This option also inserts closing quotation marks and closing 
brackets if they are missing. 

Rename Form Items When Pasting 
Ensures you don’t have duplicate names for form objects. This option is enabled by 
default. 

Note: Unlike the other options in this preferences dialog box, this option does 
not apply when you open a document, only when you copy and paste a form 
element. 

Remove Extra Closing Tags 
Deletes closing tags that have no corresponding opening tag. 

Warn When Fixing Or Removing Tags 
Displays a summary of technically invalid HTML that Dreamweaver attempted to 
correct. The summary notes the location of the problem (using line and column 
numbers) so that you can find the correction and ensure that it is rendering as 
intended. 

Never Rewrite Code: In Files With Extensions 
Allows you to prevent Dreamweaver from rewriting code in files with the specified 
filename extensions. This option is particularly useful for files that contain third-party 
tags. 

Encode <, >, &, And " In Attribute Values Using & 
Ensures that attribute values that you enter or edit using Dreamweaver tools such as 
the Property inspector contain only legal characters. This option is enabled by 
default. 

Note: This option and the following options do not apply to URLs that you 
manually type in Code view. Also, they do not cause existing code already in a 
file to change. 

Do Not Encode Special Characters 
Prevents Dreamweaver from changing URLs to use only legal characters. This option 
is enabled by default. 

Encode Special Characters In URL Using &# 
Ensures that when you enter or edit URLs using Dreamweaver tools such as the 
Property inspector, those URLs contain only legal characters. 

Encode Special Characters In URL Using % 
Operates the same way as the preceding option, but uses a different method of 
encoding special characters. This encoding method (using the percent sign) may be 
more compatible with older browsers, but does not work as well with characters 
from some languages. 
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Set COPY/PASTE preferences 
To add text to a Dreamweaver document, you can type text directly in the Document window, 
or you can copy and paste text, including text from other documents. 

When you paste text into a Dreamweaver document, you can use either the Paste or the Paste 
Special command. The Paste Special command lets you specify the format of pasted text in 
different ways. For example, if you wanted to paste text from a formatted Microsoft Word 
document into your Dreamweaver document, but wanted to strip out all embedded formatting, 
you could select the text in Word, copy it to your Clipboard, and use the Paste Special 
command - selecting the option that lets you paste text only. 

When using the Paste command to paste text from other applications, you can set paste 
preferences as default options. 

Note: Control+V (Windows) and Command+V (Macintosh) always paste text only (no 
formatting) in Code view. 

 
You can set special paste preferences as default options when using Edit > Paste to paste text 
from other applications. For example, if you always want to paste text as text only, or text with 
basic formatting, you can set the default option in the Copy/Paste Preferences dialog box. 

Preferences set in the Copy/Paste Preferences dialog box apply only to material pasted into 
Design view. 

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh). 
 

2. Select Copy/Paste from the Category list on the left. Set any of the following options: 
 
Text Only 
Paste unformatted text. If the original text is formatted, all formatting, including line 
breaks and paragraphs, will be removed. 

Text With Structure 
Paste text that retains structure, but does not retain basic formatting. For example, you 
can paste text and retain the structure of paragraphs, lists, and tables, without retaining 
bold, italics, and other formatting. 

Text With Structure Plus Basic Formatting 
Paste both structured and simple HTML-formatted text (e.g., paragraphs and tables, as 
well as text formatted with the b, i, u, strong, em, hr, abbr, or acronym tag). 

Text With Structure Plus Full Formatting 
Pasted text retains all structure, HTML formatting, and CSS styles. 
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Note: The Full Formatting option cannot retain CSS styles that come from an 
external style sheet, nor can it retain styles if the application from which you are 
pasting does not retain styles upon pasting to the Clipboard. 

Retain Line Breaks 
Retains line breaks in pasted text. This option is disabled if you have selected Text Only. 

Clean Up Word Paragraph Spacing 
Select this option if you selected Text With Structure or Text With Structure Plus Basic 
Formatting, and want to eliminate extra space between paragraphs when you paste 
your text. 

Convert smart quotes to straight quotes Converts smart quotes to straight quotes. 

 

Set CSS STYLES preferences  
CSS style preferences control how Dreamweaver writes the code that defines CSS styles. CSS 
styles can be written in a shorthand form that some people find easier to work with. Some 
older versions of browsers, however, do not correctly interpret the shorthand. 

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh) and 
from the Category list select CSS Styles.  

When Creating CSS Rules Use Shorthand For 
Check the box next to the CSS style properties Dreamweaver can write in shorthand. 

When Editing CSS Rules Use Shorthand 
Controls whether Dreamweaver rewrites existing styles in shorthand. Select If 
Original Used Shorthand to leave all styles as they already are. Select According to 
Settings Above to rewrite styles in shorthand for the properties selected in Use 
Shorthand For. 

CSS prefixes 
Check the box next to the CSS Prefix types to be added for gradients. The choices 
apply to browsers as follows: 

• -webkit applies to Safari and Chrome browsers on Android and iOS systems 
• -o applies to Opera browser 
• -ms applies to Microsoft browsers (IE and Edge) 

2. Click OK. 

 

 

Set FILE COMPARE preferences 
Dreamweaver can work with file comparison tools (also known as “diff tools”) to compare the 
code of local and remote versions of the same file, two different remote files, or two different 
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local files. Comparing local and remote versions is useful if you are working on a file locally and 
you suspect the copy of the file on the server has been modified by someone else. Without 
leaving Dreamweaver, you can view and merge the remote changes into your local version 
before putting the file to the server. 

Comparing two local files or two remote files is also useful if you keep previous, renamed 
versions of your files. If you have forgotten the changes made to a file from a previous version, 
a quick comparison will remind you. 

Before you start, you must install a third-party file comparison tool on your system. For more 
information on file comparison tools, use a web search engine such as Google Search to search 
for “file comparison” or “diff” tools. Dreamweaver works with most third-party tools. 
 

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh). 
 

2. Select File Compare from the Category list on the left. Do one of the following: 

o In Windows, click the Browse button and select the application that compares 
files. 

o On the Macintosh, click the Browse button and select the tool or script that 
launches the file comparison tool from the command line, not the actual 
comparison tool itself. 

 

Set FILE TYPES / EDITORS preferences 
Dreamweaver allows you to specify which file editing program will be used to open/edit various 
file types.  

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh). 

2. Select File Types / Editors from the Category list on the left. 
 

Choose the default editing program for file types by selecting from the options 
provided, then click Apply. 

 

Set FONTS preferences 
Dreamweaver font preferences let you view the code in the font and size you prefer. The fonts 
you select in the Fonts Preferences dialog, however, only affect the way fonts appear in 
Dreamweaver; they do not affect the way the document appears in a visitor’s browser. To 
change the fonts that appear in a browser, you need to change the text code by using the 
Property inspector or by applying a CSS rule (preferred). 

3. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh). 
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4. Select Fonts from the Category list on the left. 

5. Select an encoding type (Unicode is the default) from the Font Settings list.  
Note: To display an Asian language, you must be using an operating system that 
supports double-byte fonts. 

6. Select a font and size to use for each category of the selected encoding. 
Note: To appear in the font pop-up menus, a font must be installed on your computer. 
For example, to see Japanese text you must have a Japanese font installed. 

Proportional Font 
The font that Dreamweaver uses to display normal text (for example, text in paragraphs, 
headings, and tables). The default depends on your system’s installed fonts. For most U.S. 
systems, the default is Times New Roman 12 pt. (Medium) on Windows and Times 12 pt. on 
Mac OS. 

Fixed Font 
The font Dreamweaver uses to display text within pre, code, and tt tags. The default 
depends on your system’s installed fonts. For most U.S. systems, the default is Courier New 
10 pt. (Small) on Windows and Monaco 12 pt. on Mac OS. 

Code View 
The font used for all text that appears in the Code view and Code inspector. The default 
depends on your system’s installed fonts. 

Use dynamic font mapping 
Dynamic font mapping lets Dreamweaver check whether the selected font family has the 
necessary glyphs to render each character. If the font family lacks the glyphs, Dreamweaver 
substitutes an appropriate font family that can display the needed characters. This prevents 
unwanted characters from appearing when you use multiple languages in a single 
document. 

Enabling this option may result in a slight increase in the amount of time pages take to load 
into a browser. 

Note: This option is available only on the Windows platform. On the Macintosh, fonts 
are always dynamically mapped 

 

Set GIT preferences 
Dreamweaver supports Git, an open-source distributed version control system, to manage 
source code. With the integration of Git in Dreamweaver, you can independently work on your 
code from anywhere, and later merge your changes to a central Git repository. Git helps you 
track all the modifications in a file, and lets you revert to the previous versions as well. 

Git repositories are also helpful when you work as a team, as Git allows you to easily create and 
maintain branches. For example, if you are a designer who wants to work on a design change 
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for your site. At the same time, if another team member accommodates change requests for 
the same site, you both can work independently using Git. In this case, you both can 
independently create a branch and make your changes in your respective local repository. The 
local repository contains the full history of all the changes that you made to the source. You can 
pause and merge your changes with the central repository at any point in time. Merge ensures 
that the central repository always has the latest code with both your changes.  

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh). 

2. Select GIT from the Category list on the left. 

Choose the location of the GIT executable on your workstation, and set the other 
appropriate preference values, then click Apply. 

 

Set HIGHLIGHTING preferences 
Use the Highlighting preferences to customize the colors that identify template regions, library 
items, third-party tags, layout elements, and other special code in Dreamweaver. 

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh). 

2. Select Highlighting from the Category list on the left. Choose the appropriate options, 
then click Apply. 

Change the highlighting color by clicking the color box for an object, and then use the 
color picker to select a new color, or enter a hexadecimal value. 

Activate or deactivate highlighting for an object by selecting the Show checkbox on the 
right. 

 

Set IN-APP UPDATES preferences 
Adobe provides updates on an on-going basis to keep Dreamweaver up-to-date with the ever-
evolving technology. For example, updates to Bootstrap libraries or starter templates. 
 
You can specify how you want to download and install In-App updates: manually or 
automatically. You can also choose to disable In-App updates. 

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh). 

2. Select In-App Updates from the Category list on the left. Click an option that suits your 
requirement, then click Apply. 

• Manual – Ask before downloading updates 

• Automatic – Don’t ask, install updates as soon as they are available 

• Turn-off in-app updates – Never download and install updates 
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Set INTERFACE preferences 
You can choose a color theme according to your preferences when you start Dreamweaver. You 
can also change this preference any time. 

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh). 

2. Select Interface from the Category list on the left. Choose the appropriate options, 
then click Apply. 

Choose an App Theme to set the brightness of the work area.  

Choose a Code Theme to set the look of code in Code View. 

Selecting the Plus Sign (+) will open the New Code Theme dialog, where you can 
define a Custom Code Theme. The new theme will initially be a copy of the 
current theme in use when the Plus Sign was selected. Give the new theme a 
unique name and then click Create. 

Selecting the Minus Sign (-) will delete the currently selected theme (cannot be 
undone). 

Selecting the Pencil Icon will open a file named more.less which is where edits 
and/or additions are made to a theme, using CSS styling. 

Note: The appearance of code in Code View can be customized for each 
type of element (<a>, <p>, <div>, <img>, etc.). To learn more, see the PDF 
named CUSTOMIZE CODE COLORING. 

 

Set INVISIBLE ELEMENTS preferences 
Dreamweaver allows you to specify which elements that are not visible in a browser will be 
visible, as icons, in Design View. 

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh). 

2. Select Invisible Elements from the Category list on the left. Select which elements 
should be made visible and click Apply. 

A check-mark next to the name of the element in the dialog box means the element 
will be visible when View > Design View Options > Visual Aids > Invisible Elements is 
selected. The Icon for those elements will be displayed at the position of the 
element. Applies to Design View only. 

Named Anchors 
Displays an icon that marks the location of each named anchor (<a name= "">) in the 
document. 

Scripts 
Displays an icon that marks the location of JavaScript or VBScript code in the body of 
the document. Select the icon to edit the script in the Property inspector or to link to 
an external script file. 
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Comments 
Displays an icon that marks the location of HTML comments. Select the icon to see 
the comment in the Property inspector. 

Line Breaks 
Displays an icon that marks the location of each line break (<br>). This option is 
deselected by default. 

Client-Side Image Maps 
Displays an icon marking the location of each client-side image map in the document. 

Embedded Styles 
Displays an icon showing the location of CSS styles embedded in the body section of 
the document. If CSS styles are placed in the head section of a document, they do not 
appear in the Document window. 

Hidden Form Fields 
Displays an icon that marks the location of form fields that have the type attribute set 
to "hidden". 

Form Delimiter 
Displays a border around a form so you can see where to insert form elements. The 
border shows the extent of the form tag, so any form elements inside that border are 
properly enclosed in form tags. 

Anchor Points For AP elements 
Displays an icon that marks the location of code defining an AP (Absolute Positioned) 
element. The AP element itself can be anywhere on the page. Note that AP elements 
are not invisible elements; only the code defining the AP element is invisible. Select 
the icon to select the AP element; you can then see the contents of the AP element 
even if the AP element is marked as hidden. 

Anchor Points For Aligned Elements 
Displays an icon showing the location of HTML code for elements that accept 
the align attribute. These include images, tables, ActiveX objects, plug-ins, and 
applets. In some cases, the code for the element may be separated from the visible 
object.  

Visual Server Markup Tags 
Displays the location of server markup tags (such as Active Server Pages tags and 
ColdFusion tags) whose content cannot be displayed in the Document window. These 
tags typically generate HTML tags when processed by a server. For example, a 
<CFGRAPH> tag generates an HTML table when processed by a ColdFusion server. 
Dreamweaver represents the tag with a ColdFusion invisible element since 
Dreamweaver cannot determine the final, dynamic output of the page. 

Nonvisual Server Markup Tags 
Displays the location of server markup tags (such as Active Server Pages tags and 
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ColdFusion tags) whose content cannot be displayed in the Document window. These 
tags are typically set-up, processing, or logic tags (for example, <CFSET>, <CFWDDX>, 
and <CFXML>) that do not generate HTML tags. 

CSS Display: None 
Displays an icon showing the location of content that’s hidden by the display:none 
property in the linked or embedded stylesheet. 

Show Dynamic Text As 
Displays any dynamic text on your page in the format of {Recordset:Field} by default. 
If the length of these values is long enough to distort your page’s formatting, you can 
change the display to {} instead. 

Server-Side Includes 
Displays the actual contents of each server-side include file. 

 

Set LINTING preferences 
Linting is automated checking of your source code for programmatic and stylistic errors. HTML 
syntax errors, parsing errors in CSS, or warnings in JavaScript files are some of the things 
flagged by linting in Dreamweaver. 

Any errors and warnings found are listed in a separate Output panel - docked at the bottom of 
the workspace. Each line in the panel helps you jump to the portion of the code where the error 
has occurred, making it easy to find and fix the code. Also, the line numbers of the erroneous 
code are highlighted in red for errors and yellow for warnings. When you hover your mouse 
over the highlighted line numbers, a preview of the error or warning pops up. 

With the On Edit Linting feature selected, errors and warnings can be displayed in the output 
panel immediately, while editing the codes. 

Dreamweaver includes the option to enable or disable linting, and to determine the rules used 
by the linting tool. 

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh). 
 

2. Select Linting from the Category list on the left. Choose the appropriate options, 
then click Apply. 
 

 
Set NEW DOCUMENT preferences 
If most of the pages in your site are of a specific file type (such as HTML, PHP, or JavaScript), 
you can set document preferences that will automatically create new documents of the 
specified file type. 

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh). 
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2. Select New Document from the Category list on the left. Choose the appropriate 
options to suit your preferences, then click Apply. 

Default Document 
Select a document type that will be used for pages that you create. 
 
Default Extension 
Specify the file extension you prefer (.htm or .html) for new HTML pages you create. 

Note: This option is disabled for other file types. 
 

Default Document Type (DDT) 
The default is HTML5, which is the current encoding specification.  

Note: Only select one of the other options if you must create documents that are 
compliant with obsolete encoding specifications.  
 

Default Encoding 
Specify the encoding to be used when a new page is created, as well as when a 
document is opened that does not specify any encoding. 

Note: If you select Unicode (UTF-8) as the document encoding, entity encoding is 
not necessary because UTF-8 can safely represent all characters. If you select 
another document encoding, entity encoding may be necessary to represent 
certain characters. For more information on character entities, 
see www.w3.org/TR/REC-html40/sgml/entities.html. 
Note: If you select Unicode (UTF-8) as a default encoding, you can include a Byte 
Order Mark (BOM) in the document by selecting the Include Unicode Signature 
(BOM) option. 

A BOM is 2-4 bytes at the beginning of a text file that identifies a file as Unicode, 
as well as the byte order of the following bytes. Because UTF-8 has no byte 
order, adding a UTF-8 BOM is optional. For UTF-16 and UTF-32, it is required. 

Unicode Normalization Form 
Select one of these options if you select Unicode (UTF-8) as a default encoding. 

Note: There are four Unicode Normalization Forms. The most important is 
Normalization Form C because it is the most common one used in the Character 
Model for the World Wide Web. Adobe provides the other three Unicode 
Normalization Forms for completeness. 

In Unicode, there are characters that are visually similar but can be stored within 
the document in different ways. For example, “ë” (e-umlaut) can be represented 
as a single character, “e-umlaut,” or as two characters, “regular Latin e” + 
“combining umlaut.” A Unicode combining character is one that gets used with 
the previous character, so the umlaut would appear above the “Latin e.” Both 
forms result in the same visual typography, but what is saved in the file is 
different for each form. 

http://www.w3.org/TR/REC-html40/sgml/entities.html
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Normalization is the process of making sure all characters that can be saved in 
different forms are all saved using the same form. That is, all “ë” characters in a 
document are saved as single “e-umlaut” or as “e” + “combining umlaut,” and 
not as both forms in one document. 

For more information on Unicode Normalization and the specific forms that can 
be used, see the Unicode website at www.unicode.org/reports/tr15. 

 

Show New Document Dialog Box on Control+N 
Deselect this option (“on Command+N” for Macintosh) to automatically create a 
document of the default document type when you use the key command. 

 

Set NEW FEATURE GUIDE preferences 
Dreamweaver displays tips for new features the first time you use them. The tips are not 
displayed the next time the feature is used. However, if you want to see these tips again you 
can Reset the tips. 

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh). 
 

2. Select New Feature Guides from the Category list on the left. Choose Reset, then 
click Apply. 

 

Set PHP preferences 
Dreamweaver allows you to set which version of the PHP Development Environment to use. 

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh). 
 

2. Select PHP from the Category list on the left. Choose the preferred PHP Version, 
then click Apply. 

 

Set REAL-TIME PREVIEW preferences 
Dreamweaver allows you to select which browser(s) will be used to preview documents. 

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh). 
 

2. Select New Feature Guides from the Category list on the left. Choose the 
appropriate options, then click Apply. 

 

http://www.unicode.org/reports/tr15
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Set SITE preferences 
In Dreamweaver the term “site” refers to a local or remote storage location for the documents 
that belong to a website. 

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh). 
 

3. Select Site from the Category list on the left, choose the appropriate options, then 
click Apply. 

Always Show 
Specifies which site (remote or local) is shown by default, and in which Files panel 
pane (left or right) the local and remote files appear. 

Dependent Files 
Displays a prompt for transferring dependent files (such as images, external style 
sheets, and other files referenced in the HTML file) that the browser loads when it 
loads the HTML file. By default, both Prompt on Get/Check Out and Prompt on 
Put/Check In are selected. 

It is usually a good idea to download dependent files when checking out a new file, 
but if the latest versions of the dependent files are already on the local disk, there is 
no need to download them again. This is also true for uploading and checking in 
files: no need if up-to-date copies are already at the destination. 

 Note: If you deselect these options, your dependent files are not transferred. 
Therefore, to force the Dependent Files dialog box to appear even when these 
options are deselected, hold down Alt (Windows) or Option (Macintosh) while 
choosing the Get, Put, Check In, or Check Out commands. 

FTP Connection 
Determines whether the connection to the remote site is terminated after the 
specified number of minutes have passed with no activity. 

FTP Time Out 
Specifies the number of seconds in which Dreamweaver attempts to make a 
connection with the remote server. 

If there is no response after the specified amount of time, Dreamweaver displays a 
warning dialog box alerting you to this fact. 

FTP Transfer options 
Determines whether Dreamweaver selects the default option, after a specified 
number of seconds, when a dialog box appears during a file transfer and there is no 
user response. 

Proxy Host 
Specifies the address of the proxy server through which you connect to outside 
servers if you are behind a firewall. 



Page 18 of 20 
 

If you are not behind a firewall, leave this space blank. If you are behind a firewall, 
select the Use Proxy option in the Site Definition dialog box (Servers > Edit Existing 
Server (pencil icon) > More Options). 

Proxy Port 
Specifies the port in your proxy or firewall through which you pass to connect to the 
remote server. If you connect through a port other than 21 (the default for FTP), 
enter the number here. 

Put Options: Save Files Before Putting 
Indicates that unsaved files are saved automatically before being put onto the 
remote site. 

Move Options: Prompt Before Moving Files on Server 
Alerts you when you attempt to move files on the remote site. 

Manage Sites 
Opens the Manage Sites dialog box, where you can edit an existing site or create a 
new one. 

 

Set SYNC SETTINGS preferences 
Adobe Creative Cloud subscription accounts let you activate Dreamweaver on two machines, 
and allows you to synchronize settings so Dreamweaver behaves the same on both machines. 

Synchronization is not supported in the following scenarios: 

• You have a volume license and are signed in as an anonymous user. 

• Your machine is configured to connect to the Internet through a proxy server. 

• You switch from an Administrator account to a standard user account. 

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences 
(Macintosh). 

2. Select Sync Settings from the Category list on the left. Choose the 
appropriate options, then click Apply. 

To learn more go to https://helpx.adobe.com/dreamweaver/using/synchronizing-
dreamweaver-settings-creative-cloud.html  

 

Set W3C VALIDATOR preferences 
Dreamweaver helps you create standards-compliant web pages with its in-built support for the 
W3C validator. The W3C validator checks your HTML and CSS documents for conformance to 
current standards. You can validate both open documents, and files posted on a live server. Use 
the report that is generated after validation to fix errors in your file. 

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences 
(Macintosh). 

https://helpx.adobe.com/dreamweaver/using/synchronizing-dreamweaver-settings-creative-cloud.html
https://helpx.adobe.com/dreamweaver/using/synchronizing-dreamweaver-settings-creative-cloud.html
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2. Select W3C Validator from the Category list on the left. Choose the appropriate 
options, then click Apply. 

 

Set WINDOW SIZES preferences 
Dreamweaver comes with a set of window sizes, based on standard devices screens. The 
Window Sizes preferences menu allows you to add custom window sizes, or remove defined 
window sizes, using the Plus (+) and Minus (-) icons. 

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences 
(Macintosh). 

2. Select Window Sizes from the Category list on the left. Choose the appropriate 
options, then click Apply. 

 

 

Set CODE VIEW OPTIONS 
You can set word wrapping, display line numbers for the code, set syntax coloring for code 
elements, set indenting, and show hidden characters from the View > Code View Options 
menu. 

1. View a document in Code view or the Code inspector. 

2. Select View > Code View Options > and select or deselect any of the following options: 

Word Wrap 
Wraps the code so that you can view it without scrolling horizontally. This option does 
not insert line breaks; it just makes the code easier to view. 

Line Numbers 
Displays line numbers along the side of the code. 

Hidden Characters 
Displays special characters in place of white space. For example, a dot replaces each 
space, a double chevron replaces each tab, and a paragraph marker replaces each line 
break.   Note: Soft line breaks that Dreamweaver uses for word wrapping are not 
displayed with a paragraph marker. 

Syntax Coloring 
Enables or disables code coloring. For information on changing the coloring scheme, 
see the PDF titled CODE COLORING. 

Auto Indent 
Makes your code indent automatically when you press Enter while writing code. The 
new line of code indents to the same level as the previous line. 


