
Creating A Personal Website 

Using Adobe Dreamweaver 

 
LIBRARY ITEMS 

 

Dreamweaver provides multiple ways to work with code and includes many features to assist 
you while developing websites. Included in those features are three ways to store and reuse the 
elements that comprise website pages. You can reuse stored pieces of code using Code 
Snippets, insert pre-defined blocks of code and/or objects using Library Items, and create 
consistently styled documents across a site using Page Templates. 

Note: This document provides details on using Library Items. See the PDF titled CODE 
SNIPPETS for details on using Code Snippets, and the PDF titled PAGE TEMPLATES for 
details on using Page Templates. 

 

A Library is a special Dreamweaver folder containing a collection of library items that you can 
place in your web pages. When a library item is updated (edited and saved) it will automatically 
update each instance of that item, on all pages that include the item.  

Example: If all pages on a website include a company name and logo, you can create a 
library item that contains those elements and use it on every page. If that library item is 
changed it automatically updates on every page that uses it. 

You can create a library item from any element in the body section of a document, including 
text, tables, forms, Java applets, plug-ins, ActiveX elements, navigation bars, images, and more.  

Dreamweaver stores each library item as a separate file, with the extension .lbi, in the Library 
Folder located in the root directory for the site. If the Library Folder does not yet exist when the 
first library item is saved, Dreamweaver automatically creates a folder named Library in the site 
root directory, with the new library item file included. Any subsequently saved library items will 
be added in this Library folder. You can view the Library Folder, and the Library Items within, 
from the Files Panel. 

When you place a library item in a document, Dreamweaver inserts a linked copy of the HTML 
source code contained in that library item into the document, along with an HTML comment 
with a reference to the original in the library folder. It is this reference to the original that makes 
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automatic updating possible. It also means that library items can only be used for the specified 
site, since the reference is pointing to a specific folder location. 

If a library item includes linked assets, such as an image, the actual location of the linked asset 
must match the referenced location of that asset, as specified in the library item source code, 
or the library item will cease to work correctly.  

You can store an image as a stand-alone library item, or store a complete img tag in a library 
item. Storing an img tag allows you to change the image’s attributes, such as alt, src, and so 
forth, throughout the site.  

Note: It is not recommended to use this technique to change image width and height 
attributes, unless you also use an image editor to change the actual image size. 

When you create a library item that includes an element with a Dreamweaver behavior 
attached to it, Dreamweaver copies the element and its event handler (the attribute that 
specifies which event triggers the action, such as onClick, onLoad, or onMouseOver, and which 
action to call when the event occurs) to the library item file. Dreamweaver does not copy the 
associated JavaScript functions into the library item. Instead, when you insert the library item 
into a document, Dreamweaver automatically inserts the appropriate JavaScript functions into 
the <head> section of that document (if they are not already there). 

Note: If you hand-code JavaScript (that is, if you create it without using Dreamweaver 
behaviors), you can make it part of a library item if you use Dreamweaver’s Call 
JavaScript behavior to execute the code. If you do not use a Dreamweaver behavior to 
execute the code, the code is not retained as part of the library item. 

Note: Library items cannot contain style sheets, because the code for those elements is 
part of the <head> section. 
 
 

CREATE A NEW LIBRARY ITEM 

Create a library item based on a selection 

Design View: 

• In the Document window select a portion of the document to save as a library item. 
• Select Tools > Library > Add Object to Library. 
• Enter a name for the new library item, then press Enter (Windows) or Return 

(Macintosh). 

Code View: 

• In the Document window select a portion of the code to save as a library item. 
• In the Assets panel, select Library from the category icons on the left, then select the 

New Library Item button at the bottom of the panel. 
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• Enter a name for the new library item, then press Enter (Windows) or Return 
(Macintosh). 
 

Create an empty library item 

• Make sure nothing is selected in the Document window. (If something is selected, it 
will be placed in the new library item.) 

• In the Assets panel, select Library from the category icons on the left, then select the 
New Library Item button at the bottom of the panel. 

• Enter a name, then press Enter (Windows) or Return (Macintosh). 

 
 

Insert a library item into a document 

Note: To insert the contents of a library item without including the reference to the 
Library folder, press Control (Windows) or Option (Macintosh) while inserting the item. 
When you insert a library item this way, it can be edited the same as normal code, and 
does not retain the ability to be automatically updated if that library item is updated. 

• In the Document window, place the cursor at the insertion point. 

• In the Assets panel, select Library from the category icons on the left, then select the 
library item to be inserted. 

• Click the Insert button at the bottom of the panel. 

 

LIBRARY ITEM EDIT and UPDATE FUNCTIONS 

There are four Edit functions that can be applied to a library item: Edit, Rename, Delete, and 
Recreate.  

After applying any Edit function to a library item, you can choose to Update all documents that 
use that item, or to Update only the current document, or to Not Update at this time (you can 
update later). 

If you choose to not update some (or all) documents, then the referenced library item contents 
remain “as is” even though the actual library item has changed. This, in effect, breaks the 
connection between the not-updated documents and the updated library items. Executing a full 
update later will re-establish most connections. It is also possible, in some circumstances, to 
recreate a missing library item (details below). 
 

Edit a library item 

• In the Assets panel, select Library from the category icons on the left, then select the 
library item to be edited. 
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• Either click the Edit button or double-click the library item. 
Dreamweaver opens the library item in a new Document window, ready for editing. 

• Make any desired changes, and then select File > Save, just as with any document. 

• Specify whether to update the documents that use the library item.  

o Select Update to update immediately. 

o If you select Don’t Update, then documents won’t be updated until you 
choose Tools > Library > Update Current Page or Update Pages. 
 
 
 

Update the current document to use the current version of all library items 

• Select Tools > Library > Update Current Page. 
 

Update the entire site - all documents that use library items 

• Select Tools > Library > Update Pages. 

o In the Look In pop-up menu, specify what to update: 

1. To update all pages to the current version of all library items, select 
Entire Site, and select the Site Name from the adjacent drop-down 
menu. 

2. To update all pages that use the selected library item, select Files That 
Use, then select a Library Item Name from the adjacent drop-down 
menu. 

o Make sure that Library Items is checked in the Update options. 
Note: To update templates at the same time, select Templates as well. 
 
Note: If you select the Show Log option, Dreamweaver generates a report 
showing whether files were updated successfully, along with other 
information. 

• Click Start. Dreamweaver updates the files as indicated.  
 

Rename a library item 

• In the Assets panel, select Library from the category icons on the left, then select the 
library item to be renamed, then click again in the Name Field. (Do not double-click; 
double-clicking opens the library item for editing.) 

• Enter a new name and press Enter (Windows) or Return (Macintosh). 
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• Specify whether to update documents that use the item by choosing either Update or 
Don’t Update. 

o If you select Don’t Update, then documents won’t be updated until you 
choose Tools > Library > Update Current Page or Update Pages. 
 

Delete a library item from the library 

• In the Assets panel, select Library from the category icons on the left, then select the 
library item to be deleted. 

• Either click the Delete icon at the bottom of the panel, or press the Delete key, then 
confirm that you want to delete the item. 

 Note: When you delete a library item, Dreamweaver removes it from the library but 
does not change the contents of any documents that use the item. You cannot use 
Undo to retrieve it, but it may be possible to recreate it (see below). 
 

Recreate a missing or deleted library item 

1. Select an instance of the item in one of your documents. 

2. Click the Recreate button in the Property inspector (Window > Properties). 

 

CUSTOMIZE HIGHLIGHTING of LIBRARY ITEMS 

You can customize the highlight color of library items in Design View, and show or hide 
highlighting, by setting Highlighting preferences. 

Change the highlight color of library items 

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh). 

2. Select the Highlighting category from the list on the left of the Preferences dialog 
box. 

3. Click the Library Items color box, then select a highlight color using the color picker 
(or enter the hexadecimal color value in the text box). 

4. Select Show to display the highlight color in the Document window. (If Show is 
unchecked the highlight color will not be applied to library items in Design View.) 

5. Click OK. 
 

To show or hide highlighting in the Document window (applies to Design View) 
1. To globally allow highlighting, select View > Design View Options > Visual Aids > 

Invisible Elements. To globally hide highlighting, deselect Invisible Elements. 
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EDIT THE PROPERTIES of a LIBRARY ITEM 

You can use the Property inspector to open a library item for editing, detach a selected library 
item from its source file, or overwrite an item with the currently selected library item. 

1. Select a library item in a document. 

2. Select one of the options in the Property inspector (Window > Properties): 

Src 
Displays the filename and location of the source file for the library item. You cannot 
edit this information. 

Open 
Opens the library item’s source file for editing. This is equivalent to selecting the item 
in the Assets panel and clicking the Edit button. 
  

Detach From Original 
Breaks the link between the selected library item and its source file. You can edit the 
detached item in the document, but it is no longer a library item and is not updated 
when you change the original. 

Recreate 
Overwrites the original library item with the current selection. This option can be 
used to re-create library items if the original library item is missing or has been 
accidentally deleted. 

 

MAKE LIBRARY ITEMS EDITABLE in a DOCUMENT 

If you have added a library item to your document and you want to edit the item specifically for 
that page, you must break the link between the item in the document and the library. Once you 
have made an instance of a library item editable, that instance will no longer be updated when 
the original library item changes. 

1. Select a library item in the current document. 

2. Click Detach From Original in the Property inspector (Window > Properties). 
 

EDIT A BEHAVIOUR in a LIBRARY ITEM 

To edit a behavior in a library item, you must first insert the item in a document, then make the 
item editable in that document (see above). After you have made the changes, you can re-
create the library item, replacing the item in the library with the edited item from your 
document. 

1. Open a document that contains the library item. 
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 Note: Make note of the name of the library item, as well as the exact tags it 
contains. You will need this information later. 

2. Select the library item, and then click Detach From Original in the Property inspector 
(Window > Properties). 

3. Select the element that has the behavior attached to it. 

4. In the Behaviors panel (Window > Behaviors), double-click the action you want to 
change. 

5. In the dialog box that appears, make your changes, then click OK. 

6. In the Assets panel, select the Library category. 

7. Make note of the exact name, including capitalization, of the original library item, 
then select it and click the Delete button. 

8. In the Document window, select all the elements that make up the library item. 

9. In the Assets panel, click the New Library Item icon, then give the new item the same 
name as the item you deleted, using the same spelling and capitalization. 

10. To update the library item in your site’s other documents, select Tools > Library > 
Update Pages. 

11. In the Look In pop-up menu, select Files That Use. 

12. In the adjacent pop-up menu, select the name of the library item you just created. 

13. In the Update option, make sure Library Items is selected, then click Start. 

14. When the updates are complete, click Close. 
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