
Creating A Personal Website 

Using Adobe Dreamweaver 

 
CODE WRITING 

 

This document explores some of the many features Dreamweaver provides to assist you while 
developing web page code. Start by creating a new HTML file using the New Document dialog, 
switch to Code View, and start typing in your code. 

 

Creating a new HTML file in Dreamweaver 

As you type, Code Hints appear to help you enter appropriate code and avoid typos (see the 
PDF titled CODE HINTS for details). You can also insert code using the Insert Panel (see below), 
using Emmet Coding Abbreviations (see below), using Snippets (see the PDF titled CODE 
SNIPPETS for details), Library Items (see the PDF titled LIBRARY ITEMS for details), Templates 
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(see the PDF titled PAGE TEMPLATES for details), and much more. Read on for information on 
available Dreamweaver code writing assistance features, including: 

• The Snippets Panel is available for quickly creating and inserting pre-formatted code 
snippets into your code. (For details, see the PDF titled CODE SNIPPETS.) 

• The Multiple Cursors feature allows you to create and/or edit multiple lines of code 
simultaneously. See EDIT MULTIPLE CODE LINES, USE MULTIPLE CURSORS, below. 

• Use Dreamweaver's Find and Replace feature to search for and select tags, attributes, 
or text in code, and to delete or replace the selected elements. See FIND and REPLACE 
TEXT, below. 

• Use the Code Navigator to navigate to related code both within and outside the current 
file. See NAVIGATE TO RELATED CODE, below. 

• Use the Quick Edit feature to edit code in related files without even opening the file in a 
new tab. See QUICK EDIT, below. 

• Right-click on code to bring up a simple, relevant Context Menu that allows you to edit 
the code directly. See EDIT CODE with the CONTEXT MENU, below. 

• Use Wrap Tag to wrap text in tags. See WRAP TAG FUNCTION, below. 

 

INSERT CODE using the INSERT PANEL 
The Insert Panel contains buttons for inserting various types of objects, such as images and 
forms, into a Dreamweaver document. You can use the Insert Panel to create or insert content 
in nine categories: 

1. The Common category contains buttons for inserting commonly used objects, such as 
links, images, and tables. 

2. The Layout category gives you options to insert tables, table elements, div tags, frames, 
and Spry widgets. You can view tables in either Standard (default) mode or Expanded 
Tables mode. 

3. The Forms category contains buttons for creating forms and inserting form elements. 
4. The Data category lets you insert dynamic elements such as recordsets, repeated 

regions, and record insertion and update forms. 
5. The Spry category lets you insert “widgets” that display data from other files and various 

interface elements (such as navigation bars and menus) that rely on JavaScript and CSS. 
(Spry widgets are not covered in this document, but you can find out more about them 
in Dreamweaver Help (select Help > Dreamweaver Help and look for the section called 
“Building Spry pages visually.”) 

6. The jQuery Mobile category provides content layout options, input, UI and form 
controls for developing mobile applications using Dreamweaver. 

7. The InContext Editing category is used to enable end users to make simple edits to their 
web pages without help from you or additional software on their computers. Adobe 
InContext Editing (ICE) is an online hosted service that provides simple content editing 
capabilities within a web browser. 

8. The Text category is used for working in Code View and enables you to insert a variety 
of text and list-formatting tags, such as b, em, p, h1, and ul. 
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9. Use the Favorites category to customize a list of Insert panel buttons for fast access. You 
can customize this category by right-clicking (Windows) or Control-clicking (Mac OS) the 
Insert Panel. 

 
The Insert Panel menu 

• To hide or show the Insert Panel select Window > Insert. 
• Switch between categories by using the Insert Panel drop-down menu, which is located 

at the top of the Insert panel. 
 
Inserting an object 

1. Position the cursor at the insertion point in the code. 
2. Select an object category from the Insert Panel drop-down menu. 
3. Click an object button. 
4. The code appears in your page immediately, or a dialog box appears requesting more 

information to complete the code. 
Note: The number and type of buttons available in the Insert panel varies depending on 
the current document type, the object category selected, and whether you are using 
Code View or Design View. 

 

INSERT CODE using the EMMET TOOLKIT 
Emmet is a plug-in that allows high-speed generation of HTML and CSS code. Emmet 
Abbreviations can be used in Code View or Code Inspector.  

In a document that uses Emmet press the Tab key to expand the abbreviations into HTML 
markup or CSS. HTML abbreviations expand in HTML and PHP pages. CSS abbreviations expand 
in CSS, LESS, SASS, SCSS pages, or within the style tag in an HTML page. 
 

Below are a few examples that demonstrate how you can use Emmet Abbreviations in Code 
View. 
 
Example 1: Inserting HTML code using Emmet 
To quickly add HTML code for an unordered list with three elements, open the HTML file and 
type the following Emmet abbreviation within the <body></body> tags: 
 

div>(ul>li*3>{Lorem Ipsum})+p*4>lorem 
 

Next, with the cursor placed immediately after the Emmet abbreviation, press Tab to expand 
the abbreviation. Alternatively, select the entire abbreviation and then press Enter. 
 

The abbreviation expands to the following code: 

 <div> 
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    <ul> 

        <li>Lorem Ipsum</li> 

        <li>Lorem Ipsum</li> 

        <li>Lorem Ipsum</li> 

    </ul> 

    <p>Lorem ipsum dolor sit amet, consectetur adipisicing elit. Saepe, voluptatum, 
perferendis ad impedit iste assumenda et laborum doloribus optio molestiae perspiciatis 
modi quaerat corrupti velit cupiditate eligendi tempora temporibus vel.</p> 

    <p>Ipsa, distinctio, eveniet ad numquam libero quam doloremque culpa illo ex 
possimus eligendi amet nesciunt provident inventore rerum facere ea veritatis itaque? 
Suscipit rem asperiores excepturi sapiente enim architecto esse.</p> 

    <p>Harum, ad porro molestiae corporis natus aut non fugit. Recusandae, 
reprehenderit, voluptate voluptas reiciendis voluptatum tempora vero vel libero facere 
fuga maiores ratione eaque ad illum porro dignissimos sit eos.</p> 

    <p>Dignissimos, molestiae, quis ducimus ratione temporibus sed accusamus libero 
consequuntur ex velit maiores illum repudiandae cum! Dolorum, dolore, pariatur, 
incidunt in saepe laudantium consequatur provident totam vero velit nobis 
accusantium!</p> 

</div> 

 

Example 2: Inserting CSS code using Emmet 
To insert CSS code for creating a border radius with vendor prefixes, open your CSS file and type 
the following Emmet abbreviation inside a class definition: 

-bdrs 

When you press Tab, the abbreviation expands to the following code: 

-webkit-border-radius: ; 

-moz-border-radius: ; 

border-radius: ; 

 

CODE COMMENTS 
A comment is descriptive text that you insert in HTML code to explain the code or provide other 
information. The text of a comment appears only in Code View and is not displayed in Design 
View, Live View, or when the page is viewed in a browser. 
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Add comments to your code 
To add comments do one of the following: 

1. Place your cursor at the insertion point, click the Apply Comment icon in the Common 
Toolbar, and select the appropriate syntax (HTML Comment, for example). An empty 
Comment Block will be inserted. Enter the comment text within the new comment 
block. (For more information on the Common Toolbar, see the PDF titled OVERVIEW.) 

2. Place your cursor at the insertion point and type the comment text. Select the comment 
text, click the Apply Comment icon in the Toolbar, and select the appropriate syntax 
(HTML Comment, for example). The selected text is wrapped in a comment block. 
 

 
Adding comments 

You can also use the Ctrl+/ (on Windows), or Cmd+/ (on Mac) keyboard shortcuts to 
add comments. If you use the keyboard shortcut without selecting any text, the comment is 
applied for the current line. If you select text and use the keyboard shortcut, the comment is 
applied for the selected text. 

Remove comments from your code 
To remove code comments, select the Comment Block, and click the Remove Comment icon in 
the Toolbar.  
Note: This does not remove the comment text inside the comment block, it just removes the 
comment syntax. To remove the entire comment, including text, select the entire comment 
block (syntax and text) and hit the Delete key. 

Toggle code comments 
To toggle between showing and hiding comments in Code View, simply press Ctrl+/ on 
Windows, or Cmd+/ on Mac for the selected comment or line. 

 

INSERT CODE using SNIPPETS 
If you find yourself repeating simple code blocks multiple times, you can use Code Snippets to 
speed up the process. Write the code once, save it as a snippet using the Snippets Panel, and 
then double-click it in the Snippets Panel to insert it in your documents. (For more information 
on using Snippets, see the PDF titled CODE SNIPPETS.) 
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EDIT MULTIPLE CODE LINES, USE MULTIPLE CURSORS 
Add cursors in multiple places, or select multiple sections of code and edit them simultaneously 
using Dreamweaver's multiple cursor feature. 

Note: Copy and Paste, and Find and Replace operations do not work with multiple 
cursors or multiple selections. 

 
Add multiple cursors or multiple selections 
You can add multiple cursors in different ways depending on your requirements. If you want to 
add the same text in multiple places without replacing any existing text, add multiple cursors. If 
you want to replace existing text, you can make multiple selections - continuous lines of text, or 
discontinuous lines of text, or both - and add cursors to them. 
 
To add multiple cursors or multiple selections on the same column across continuous lines: 
Hold down the Alt key, then click drag vertically. When you drag vertically, cursors are added to 
each line you drag across. Below is a video example: 
 

 
Video example: Text added at cursors over multiple lines 

 
To select continuous lines of text, press the Alt key and drag diagonally. When you drag 
diagonally, Dreamweaver selects a rectangular block of text within that selection.  
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Select and update multiple lines of text simultaneously 

Note: To quickly add cursors or include multiple lines in a selection, use the Shift-Alt-Up 
or Shift-Alt-Down keyboard shortcut.  

Once you have added the cursors (or selected the text) in multiple places, you can start 
typing. If you have multiple cursors, then new text is added. If you have selected content in 
multiple lines of text, then the selected text is replaced with the new text you enter. 

To add multiple cursors on different columns across lines:  
To add cursors to discontinuous lines of text, simply press the Ctrl key, and click the different 
lines where you want to place the cursor. 
 

 
Adding cursors to multiple discontinuous lines of text 

To select discontinuous lines of text, select some text, then press the Ctrl key (Windows), or 
Cmd key (Mac), and continue to make further selections. Below is a video example: 
 



Page 7 of 16 
 

 

 
To add cursors at the beginning/end of each line: 
Select multiple lines of text and press the Left or Right arrow keys. 
 
To add cursors in preceding or following lines for a selection: 
Press Shift+Alt+Up or Shift+Alt+Down keys and then press the right arrow key. 
 
To select continuous and discontinuous lines of text: 
You can combine these techniques to select both continuous and separate lines of text within a 
single selection. First select the discontinuous lines of text, then press Ctrl-Alt (on Windows) or 
Cmd-Alt (on Mac) and drag to add a set of lines to the existing multiple selections. 
 

 
Select both continuous and discontinuous lines of text 

 

CSS HELP using QUICK DOCS 
While working with CSS, LESS, or SCSS files in Dreamweaver, you can quickly get more information about 
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CSS properties or values. Place your cursor within a property or value and press Ctrl + K, Dreamweaver 
opens documentation from the Web Platform Docs project. 

You can simultaneously open multiple inline editors and doc viewers. 

 
CSS documentation within Dreamweaver 

To close a single inline editor or doc viewer, click the "X" in the upper-left or press Escape while 
Quick Docs is in focus. To close all inline editors and docs, place your cursor back in the main 
enclosing code editor and press Escape. 

ANALYZE CODE (LINTING) 
Dreamweaver supports linting (analyzing code for potential errors) for HTML, CSS, 
and JavaScript. The Output panel lists the errors and warnings detected through linting. For 
more information, see Lint code. 

In addition, Dreamweaver also shows a quick error preview in the line number column of the 
erroneous line. The line number is displayed in red to indicate that it contains errors, and when 
you hover over it, a brief description of the error is displayed. 

Note: Only the first error in the line is displayed. If the line contains only a warning, the 
description of the warning is displayed. If the line contains a warning and an error, only the 
error description is displayed. 
 
 
WRAP TAG FUNCTION 
Use the Wrap Tag function in Code View to wrap selected text, or lines of text, with a tag. In 
Design View or Live View, you can use this feature to wrap selected objects with a tag. 
 

1. Select text in Code View or an object in Design/Live View, and press Ctrl+T on your 
keyboard. A pop-up menu appears with a list of appropriate HTML tags. 

https://helpx.adobe.com/dreamweaver/using/linting-code.html
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2. Select a tag from the menu. If you are working in Code View, then the selected text gets 
wrapped with the tag. If you are working in Design or Live View, the selected object gets 
wrapped with the tag. 

 

EDIT CODE with the CONTEXT MENU 
Dreamweaver's Context Menu allows you to make quick edits to your code. To access the 
Context Menu, right-click (on Windows) or Command-click (on Mac). The following options are 
available for you to use: 
Quick Edit 
Click this option to enter Quick Edit mode. In this mode, Dreamweaver provides context-specific 
code and tools inline allowing you to quickly get to the code section you need. For more 
information, see QUICK EDIT, below.  
 
Cut, Copy, Paste 
Click these options to quickly cut, copy, and paste text without having to access the Edit menu. 
 
Find and Replace, Find Next, Find Previous 
Click these options to find, and (when desired) replace code quickly without having to access 
the Find menu. 
 
Create New Snippet 
Use this option to create Code Snippets that you can save for later reuse. Select the code, and 
click Create New Snippet to make the selected code into a snippet. For more information, 
see Work with code snippets. 
 
Open related file 
Right click over a link/script tag and click on open related file to open the file. 
 
Attach Style Sheet 
Attach an existing CSS style sheet to your page (inserts a link). 
 
Selection 
The Selection submenu includes various code editing options that you can use on a selected 
piece of code, such as toggle line and block comments, expand and collapse selection, convert 
inline CSS to rules, move CSS rules, and print code. 
 
Code Navigator 
Click this option to navigate to related code sources, such as internal and external CSS rules, 
server-side includes, external JavaScript files, parent template files, library files, and iframe 
source files. For more information, see Navigate to related code. 
 

https://helpx.adobe.com/dreamweaver/using/writing-editing-code.html#work_with_code_snippets
https://helpx.adobe.com/dreamweaver/using/writing-editing-code.html#navigate_to_related_code
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Code Hint Tools 
The Code Hint Tools submenu provides access to the color picker, URL browser, and Font list 
tools. 
 
 
INDENT CODE BLOCKS 
As you write and edit code in Code View or the Code Inspector, you can change the indentation 
level of a selected block or line of code, shifting it right or left by one tab. 

Indent the selected block of code 
Press Tab, or press Ctrl+], or select Edit > Indent Code. 

Unindent the selected block of code 
Press Shift+Tab, or press Ctrl+[, or select Edit > Outdent Code. 

 

NAVIGATE TO RELATED CODE 
The Code Navigator displays a list of code sources related to a particular selection on your 
page. Use it to navigate to related code sources, such as internal and external CSS rules, server-
side includes, external JavaScript files, parent template files, library files, and iframe source files.  
 
When you click a link in the Code Navigator, Dreamweaver opens the file containing the 
relevant piece of code. The file appears in the related files area, if it is enabled. If you do not 
have related files enabled, Dreamweaver opens the selected file as a separate document in the 
Document window. 

If you click a CSS rule in the Code Navigator, Dreamweaver takes you directly to that rule. If the 
rule is internal to the file, Dreamweaver displays the rule in Split View. If the rule is in an 
external CSS file, Dreamweaver opens the file and displays the rule in the related files area 
above the main document. 

You can access the Code Navigator from Design View, Code View, or Split View, and from the 
Code inspector. 

For a video overview from the Dreamweaver engineering team about working with the Code 
Navigator, see www.adobe.com/go/dw10codenav. 
 
For a video tutorial on working with Live View, related files, and the Code Navigator, 
see www.adobe.com/go/lrvid4044_dw. 
 
Open the Code Navigator 
Alt+click (Windows) or Command+Option+Click (Macintosh) anywhere on the page. The Code 
Navigator displays links to the code affecting the area you clicked. 

Click outside the Code Navigator to close it. 

https://www.adobe.com/go/dw10codenav
https://www.adobe.com/go/lrvid4044_dw
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Note: You can also open the Code Navigator by clicking the Code Navigator indicator 
. This indicator appears near the insertion point on your page when the mouse has been 
idle for 2 seconds. 
 

Navigate to code with the Code Navigator 
1. Open the Code Navigator from the area of the page that you are interested in. 

2. Click the piece of code you want to go to. 

The Code Navigator groups related code sources by file and lists the files alphabetically. For 
example, suppose that CSS rules in three external files affect the selection in your document. In 
this case, the Code Navigator lists those three files and the CSS rules relevant to the selection. 
For CSS related to a given selection, the Code Navigator functions like the CSS Styles Panel in 
Current Mode. 

Note: When you hover over links to CSS rules, the Code Navigator displays tool tips of 
the properties in the rule. These tool tips are useful when you want to distinguish 
between many rules that share a name. 
 

Disable the Code Navigator indicator 
1. Open the Code Navigator. 

2. Select Disable Indicator in the lower-right corner. 

3. Click outside the Code Navigator to close it. 

To re-enable the Code Navigator indicator, Alt+Click (Windows) or Command+Option+Click 
(Macintosh) to open the Code Navigator and deselect the Disable Indicator option. 

QUICK EDIT 
The Quick Edit mode in Dreamweaver puts context-specific code and tools inline, allowing you 
to quickly get to the code section you need. 

To enter Quick Edit mode: 

• Right-click a code snippet and select Quick Edit from the context menu that appears 

• Press Ctrl + E (on Windows) or Cmd+E (on Mac) 
 

Using Quick Edit mode with HTML files 
In an HTML file, place your cursor inside a class attribute or id attribute (name or value) or in 
the tag name. Quick Edit shows you all the CSS, SCSS, and LESS rules in your project that match. 
You can edit these rules directly inline, without ever leaving the context of the HTML file. 
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Using Quick Edit mode with HTML files 

When multiple rules match, navigate among them using the list on the right side (or use Alt-Up 
/ Alt-Down). 

To create a CSS rule directly from the inline editor, click New Rule or press Ctrl-Alt-N (on 
Windows) or Cmd-Opt-N (on Mac). 

Using Quick Edit mode with JavaScript files 
In a JavaScript file, place the cursor on a function name. Quick Edit shows you the function's 
body (even if it is present in other files referenced by a require() statement). 
 

Using Quick Edit mode with JavaScript files 

 

Using Quick Edit mode with CSS, SCSS, or LESS files 
When you bring up Quick Edit with your cursor within a color value, you can access the color 
picker and quickly modify the colors used in your CSS code. 

In a CSS, LESS, or SCSS file, place the cursor on a cubic-bezier() or steps() transition timing 
function and Quick Edit displays a graphical transition curve editor. 

Pre-defined timing functions ease, ease-in, ease-out, ease-in-out, step-start, and step-end are 
also valid starting points. 
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Manipulating a Bezier curve using Quick Edit 

 

FIND and REPLACE TEXT 
You can use Dreamweaver's Find and Replace features to search for any kind of text, code, or 
whitespace in your site, or folder, or current document. You can search the entire markup, or you can 
limit the search to just the rendered text in Design View, or to just the code. 

You can also use powerful pattern-matching algorithms (regular expressions) for sophisticated 
find-and-replace operations. 

Once you find the text, you can then choose to replace it with your specified text, code, or 
whitespace. 

 
PREVIEW IMAGES and COLORS in CODE VIEW 
Hover your mouse over any image URL to see a preview of the image in Code View. You can 
preview images that are referenced as any of the following: 

• url(); 

• data-uri() 

• Src attribute value of img tag 

Dreamweaver also shows image previews of remotely hosted images. If Dreamweaver is unable 
to display the preview for remote paths, it displays an "Unable to load image" message. 

You can preview the following image types: 

• JPEG or JPG 

• PNG 
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• GIF 

• SVG 

 
Image preview in Code view 

Hover your mouse over color values to preview colors in Code View. Supported formats are: 

• 3 and 6 digits Hexadecimal color values: #ff0000; 

• RGB: rgb(0, 0, 0); 

• RGBA: rgba(0, 255, 228,0.5); 

• HSL: hsl(120, 100%, 50%); 

• HSLA: hsla(120, 60%, 70%, 0.3); 

• Pre-defined color names, such as, Olive, Teal, red. 

Color preview is available in all document types for the above color formats. 

 
Color preview in Code view 
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Right-click a value and select Quick Edit to open the color picker and select a different color. 
 

Note: To disable previews for images and colors, uncheck the option View > Code View 
Options > Asset Preview. 

 


