
Creating A Personal Website 

Using Adobe Dreamweaver 

 
CODE FORMATTING 

 

 
You can choose a color theme for the Dreamweaver workspace. You can also set code format 
properties for Code View, including indentation and line break rules, a custom color and/or 
font for individual tags, and more. Dreamweaver supports code formatting for HTML, CSS, JS, 
and PHP file types. 
 

INTERFACE PREFERENCES 
You can choose an application workspace color theme, and change this preference any time. 

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh). 

2. Select Interface from the Category list on the left. 

3. Select a workspace background theme from the App Theme choices.  

4. Select a code theme from the Code Theme list.  
(Note: For information on developing custom Code Coloring schemes, see the PDF titled 
CUSTOMIZE CODE COLORING.) 

5. Click Apply to save the changes. (Note: Any changes made will be discarded if you close 
the Interface Preferences dialog without clicking Apply.) 

CODE VIEW OPTIONS 
You can set some basic preferences for Code View – such as word wrapping, displaying line 
numbers for the code, syntax coloring for code elements, indenting, and more – as follows: 

1. View a document in Code view or the Code Inspector. 

2. Select View > Code View Options. 

3. Select or deselect any of the following options: 

Word Wrap 
Wraps the code so that you can view it without scrolling horizontally. This option does 
not insert line breaks or otherwise alter the code; it just makes the code easier to view. 
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Line Numbers 
Displays line numbers along the side of the code. 

Hidden Characters 
Displays special characters in place of white space. For example, a dot replaces each 
space, a double chevron replaces each tab, and a paragraph marker replaces each line 
break. (Note: Soft line breaks that Dreamweaver uses for word wrapping are not 
displayed with a paragraph marker.) 

Syntax Coloring 
Enables or disables code coloring.  

Auto Indent 
Makes your code automatically indent to the same level as the previous line when you 
press Enter while writing code. For information on changing the indent spacing, see the 
Tab Size option in the CODE FORMAT PREFERENCES section, below. 
 

CODE FORMAT PREFERENCES 
You can change the look of your code by specifying Code Format rules: 

1. Select Edit > Preferences. 

2. Select Code Format from the Category list on the left. 

3. Set any of the following options: 

Indent 
Indicates whether code generated by Dreamweaver should be indented (according to 
the indentation rules specified in these preferences) or not. 

Most of the indentation options in this dialog box apply only to code generated by 
Dreamweaver, not to code that you manually type. To make manually entered code 
indent to the same level as the previous line, select View > Code View Options > Auto-
Indent option, as described in the CODE VIEW OPTIONS section, above. 

With 
(Text box and drop-down menu) Specifies how many spaces or tabs Dreamweaver 
should use to indent code that it generates. For example, if you type 3 in the box and 
select Tabs in the pop-up menu, then code generated by Dreamweaver is indented 
using 3 tab characters for every level of indentation. 

Tab Size 
Determines how many characters wide each tab character appears in Code View. For 
example, if Tab Size is set to 4, then each tab is displayed in Code view as a four-
character-wide blank space. If, additionally, Indent With is set to 3 Tabs, then code 
generated by Dreamweaver is indented using 3 tab characters for every level of 
indentation, which appears in Code view as a twelve-character-wide blank space. 

https://helpx.adobe.com/dreamweaver/using/setting-coding-preferences.html#change_the_code_format
https://helpx.adobe.com/dreamweaver/using/setting-coding-preferences.html#set_the_code_appearance
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Dreamweaver indents using either spaces or tabs; it does not convert a run of spaces to 
a tab when inserting code. 

Emmet 
Select this option if you plan to use Emmet abbreviations as you code. Selecting this 
option ensures that when you press Tab, Dreamweaver converts the Emmet 
abbreviation into full HTML or CSS code. For more information on using Emmet, see:  
https://helpx.adobe.com/dreamweaver/using/writing-editing-code.html#emmet  

Line Break Type 
Specifies the type of remote server (Windows, Macintosh, or UNIX) that hosts your 
remote site. Choosing the correct type of line break characters ensures that your HTML 
source code appears correctly when viewed on the remote server. This setting is also 
useful when you are working with an external text editor that recognizes only certain 
kinds of line breaks. For example, use CR LF (Windows) if Notepad is your external 
editor, and use CR (Macintosh) if SimpleText is your external editor. 

For servers that you connect to using FTP, this option applies only to binary transfer 
mode; the ASCII transfer mode in Dreamweaver ignores this option. If you download 
files using ASCII mode, Dreamweaver sets line breaks based on the operating system of 
your computer; if you upload files using ASCII mode, the line breaks are all set to CR LF. 

TD Tag: Do Not Include A Break Inside The TD Tag 
Addresses a rendering problem that occurs in some older browsers when white space or 
line breaks exist immediately after a <td> tag, or immediately before a </td> tag. When 
you select this option, Dreamweaver does not write line breaks after a <td> or before a 
</td> tag, even if the formatting in the Tag Library indicates that the line break should 
be there. 

Advanced Formatting: Tag Libraries 
Opens the Tag Library Editor, used to set advanced formatting options for individual 
tags and attributes. Details on using the Tag Library Editor are included later in this 
document (See Managing Tag Libraries). 

Minimum code folding size 
The default code folding size is two lines. With this default setting, all code fragments 
that have at least two lines of code are collapsible. Code fragments that are lesser than 
two lines can be collapsed only by selecting the code. For more information on code 
folding, see the section titled COLLAPSE and EXPAND CODE, below. 

Note: All Code Format options are automatically applied to new documents or additions to 
documents that you subsequently create. To reformat existing HTML code select Edit > Code > 
Apply Source Formatting.  
 

CODE REWRITING PREFERENCES 
Code Rewriting preferences specify how, and whether, Dreamweaver modifies your code while 

https://helpx.adobe.com/dreamweaver/using/writing-editing-code.html#emmet
https://helpx.adobe.com/dreamweaver/using/collapsing-code.html
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opening and/or editing documents. These preferences apply only to edits made in Design View 
and have no effect when you edit HTML or scripts in Code View. 

If you disable the rewriting options, invalid-markup items are displayed in the Document 
window for HTML that would have been rewritten. 

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh). 

2. Select Code Rewriting from the Category list on the left. 

3. Set any of the following options: 

Fix Invalidly Nested and Unclosed Tags 
Rewrites overlapping tags. For example, <b><i>text</b></i> is rewritten 
as <b><i>text</i></b>. This option also inserts closing quotation marks and closing 
brackets if they are missing. 

Rename Form Items When Pasting 
Ensures there are no duplicate names for form objects. This option is enabled by 
default. 

Unlike the other options in this preferences dialog box, this option does not apply when 
you open a document, only when you copy and paste a form element. 

Remove Extra Closing Tags 
Deletes closing tags that have no corresponding opening tag. 

Warn When Fixing Or Removing Tags 
Displays a summary of technically invalid HTML that Dreamweaver attempted to 
correct. The summary notes the location of the problem (using line and column 
numbers) so that you can find the correction and ensure that it is rendering as intended. 

Never Rewrite Code: In Files with extensions [list box] 
Allows you to prevent Dreamweaver from rewriting code in files with the specified 
filename extensions. This option is particularly useful for files that contain third-party 
tags. 

Encode <, >, &, And " In Attribute Values Using & 
Ensures that attribute values that you enter or edit using Dreamweaver tools such as 
the Property Inspector contain only valid characters. This option is enabled by default. 

This option, and the following options, do not apply to URLs that you type in Code View. 
Also, they do not cause existing code already in a file to change. 

Do Not Encode Special Characters 
Prevents Dreamweaver from changing URLs to use only valid characters. This option is 
enabled by default. 

Encode Special Characters In URL Using &# 
Ensures that when you enter or edit URLs using Dreamweaver tools such as the Property 
Inspector, those URLs contain only valid characters. 
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Encode Special Characters In URL Using % 
Operates the same way as the preceding option, but uses a different method of 
encoding special characters. This encoding method (using the percent sign) may be 
more compatible with older browsers, but does not work as well with characters from 
some languages. 
 

CODE HINTS PREFERENCES 
Configure how you want Code Hints to work.  

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh). 

2. Select Code Hints from the category on the left. 

3. Set any of the following options: 

Close tags 
Specify how you want Dreamweaver to close tags. 

o After typing "</" - Select this option if you want Dreamweaver to automatically 
complete the closing tag after you insert the closing slash. 

o After typing the open tag's ">" - Select this option if you want Dreamweaver to 
automatically add a closing tag after you insert the opening tag. 

o Never - Set this option if you do not want Dreamweaver to automatically add 
closing tags. 

Enable code hints 
Select this option to enable or disable Code Hinting and Code Completion in 
Dreamweaver. For more information on Dreamweaver's code hinting and code 
completion features, see the section titled CODE HINTS and COMPLETION, below. 

Enable description tooltips 
Select this option to enable descriptions to appear with your code hints. These 
descriptions provide additional information about the code you are writing. 

Auto-insert braces   
When checked, a closing brace is automatically inserted whenever a user types an 
opening brace. When unchecked, a closing brace is not automatically inserted. Applies 
to all types of braces and all file types (HTML, PHP, CSS, JS). 

Auto-insert quotes   
When checked, a closing quote Is automatically inserted whenever a user types an 
opening quote. When unchecked, a closing quote is not automatically inserted. Applies 
to both single and double quotes and all file types (HTML, PHP, CSS, JS). 
 

AUTO-CLOSE BRACKETS 
You can enable or disable the auto closing of brackets and quotes as follows: 
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1. Open the brackets.json file from the following location: 

o Win: %appdata%\Adobe\Dreamweaver CC 2018\en_US\Configuration\Brackets\ 

o Mac: ~/Library/Application Support/Adobe/Dreamweaver CC 
2018/en_US/Configuration/Brackets/ 

2. To disable auto closing of brackets and parentheses, set autoCloseBraces to False. 

3. To disable auto insertion of matching quotes, set autoCloseQuotes to False. 

Note: If you want to enable auto closing, set the values to True. 

Set preference for auto completion of code in Dreamweaver 

4. Save the brackets.json file, and launch Dreamweaver. 
 

PHP PREFERENCES 
You can set the PHP coding/development environment you want to work in. You can do this on 
a site-specific basis for individual sites you work on, or on a general basis for all PHP files saved 
outside Dreamweaver sites. Dreamweaver sets up the code hints, and linting checks for the 
selected PHP language version. 

To set PHP code version preferences for non-site-specific files, complete the following steps: 

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh). 

2. Select PHP from the category list on the left. 

3. Choose a PHP version from the PHP Version drop-down list and click Apply. 

To set the PHP version for a specific site, complete the following steps: 

1. In the Site Setup dialog box, under Advanced Settings, select PHP. 

2. Choose a PHP version from the PHP Version drop-down list and click Save. 
 

MANAGING TAG LIBRARIES 
A Dreamweaver Tag Library is a collection of tags of a particular type (HTML tags, for example), 
along with information about how Dreamweaver should format the tags. Tag libraries provide 
the information that Dreamweaver uses for Code Hints, Target Browser checks, the Tag 
Chooser, and other coding capabilities. 
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Using the Tag Library Editor, you can add, delete, and change tag libraries, individual tags, 
attributes, and attribute values. 

1. Select Tools >Tag Libraries  
       - or - 
Select Edit > Preferences > Code Format > Advanced Formatting: Tag Libraries 

The Tag Library Editor dialog box appears. (The options of this dialog box change 
depending on the selected tag.) 

2. Close the Tag Library Editor in one of the following ways: 

o To save changes, click OK. 

o To close the editor without saving changes, click Cancel. 
Note: When you click Cancel, all changes made in the Tag Library Editor are 
discarded, and any deleted items are restored. 
 

Add libraries, tags, and attributes 
You can use the Tag Library editor to add tag libraries, tags, and attributes to the tag libraries 
in Dreamweaver. 

Add a tag library 

1. In the Tag Library editor (Tools > Tag Libraries), click the Plus (+) button, and select 
New Tag Library. 

2. In the Library Name box, type a name (for example, Miscellaneous Tags), and click 
OK. 

Add tags to a tag library 

1. In the Tag Library editor (Tools > Tag Libraries), click the Plus (+) button and select 
New Tags. 

2. Select a library type (HTML, for example) from the Tag Library drop-down menu. 

3. Type the name of the new tag. To add more than one tag, separate tag names with a 
comma and a space (for example: cfgraph, cfgraphdata). 

4. If the new tags have corresponding end tags (</...>), select Have Matching End 
Tags. 

5. Click OK. 

Add attributes to a tag 

1. In the Tag Library editor (Tools > Tag Libraries), click the Plus (+) button and select 
New Attributes. 

2. In the Tag Library pop-up menu, select a tag library. 
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3. In the Tag pop-up menu, select a tag. 

4. Type the name of the new attribute. To add more than one attribute, separate 
attributes’ names with a comma and a space (for example: width, height). 

5. Click OK. 
 

Set properties for a tag library 

1. In the Tag Library editor (Tools > Tag Libraries), select a tag library (not a tag) in the 
Tags list. 
Note: The properties for tag libraries appear only when a tag library is selected. Tag 
libraries are represented by the top-level folders in the Tags list; for example, the 
HTML Tags folder represents a tag library, while the abbr folder, within the HTML 
Tags folder, represents a tag. 

2. In the Used In list, select every document type that should use the tag library. 

The document types you select here determine which document types provide code 
hints for the given tag library. For example, if the HTML option is not selected for a 
given tag library, code hints for that tag library do not appear in HTML files. 

3. (Optional) Enter the prefix for the tags in the Tag Prefix box. 
Note: A prefix is used to identify a tag in the code as part of a particular tag library. 
Some tag libraries do not use prefixes. 

4. Click OK. 
 

Edit a tag in a tag library 

1. In the Tag Library editor (Tools > Tag Libraries), expand a tag library in the Tags list 
and select a tag. 

2. Set any of the following Tag Format options: 

Line Breaks 
Specifies where Dreamweaver inserts line breaks for a tag. 

Contents 
Specifies how Dreamweaver inserts the contents of a tag; that is, if it applies line 
break, formatting, and indentation rules to the content. 

Case 
Specifies the case for a specific tag. Select from Default, Lowercase, Uppercase, or 
Mixed Case. If you select Mixed Case, the Tag Name Mixed Case dialog box appears. 
Type the tag with the case Dreamweaver should use when inserting it (for 
example, getProperty) and click OK. 

Set Default 
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Sets the default case for all tags. In the Default Tag Case dialog box that appears, 
select <UPPERCASE> or <lowercase>, and click OK. 
Note: You might want to set your default case to be lowercase to comply with XML 
and XHTML standards. 
 

Edit an attribute for a tag 

1. In the Tag Library editor (Tools > Tag Libraries), expand a tag library in the Tags box, 
expand a tag, and select a tag attribute. 

2. In the Attribute Case pop-up menu, select the Default, Lowercase, Uppercase, or 
Mixed Case option. 

If you select Mixed Case, the Attribute Name Mixed Case dialog box appears. Type 
the attribute with the case Dreamweaver should use when inserting it (for 
example, onClick), and click OK. 

Click the Set Default link to set the default case for all attribute names. 

3. In the Attribute Type pop-up menu, select the type of the attribute. 

If you select Enumerated, type every allowed value for the attribute in the Values 
box. Separate the values with commas, but no spaces. For example, the enumerated 
values of the showborder attribute of the cfchart tag are listed as yes,no. 
 

Delete libraries, tags, and attributes 

1. In the Tag Library editor (Tools > Tag Libraries), select a tag library, tag, or attribute 
in the Tags box. 

2. Click the Minus (–) button. 

3. Click OK to permanently delete the item. 

The item is removed from the Tags box. 

4. Click OK to close the Tag Library editor and complete the deletion. 

 
 

COLLAPSE and EXPAND CODE 
In Code View you can Collapse (also called Fold) and Expand code fragments to view different 
sections of your document without scrolling. 

For example, to see the CSS rules in the <head> tag that apply to a <div> tag farther down the 
page, fold the code between the <head> and <div> tags to see both sections of code at once. 
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You can select a portion of code to collapse it. You can also collapse code in HTML, PHP, XML, 
and SVG files based on tag blocks. In CSS, Less, Sass, SCSS, and JS files, you can collapse code 
based on curly brackets. 

• HTML files: Dreamweaver collapses the code between an opening and closing HTML 
tag, and the initial attributes (if applicable), are displayed in the collapsed code. 
Dreamweaver auto-expands when the code within the block receives focus through Tag 
Selector, Find and Replace, Go To Line, Element Quick View, Live View, or Undo/Redo. 

If the selection changes, the code is automatically collapsed back again. 

• CSS, Less, Sass, SCSS, and JS files: Code within curly brackets is collapsed and the 
preview is displayed as {...}. 

• PHP files: HTML elements, CSS, and JS code blocks are collapsed in addition to PHP code 
blocks.  

Note: Files created from Dreamweaver templates display all code as fully expanded, even if the 
template file (.dwt) contains collapsed code fragments. 
 
Set Code Folding Size Preferences 
The default code folding size is two lines. With this default setting, all code fragments that have 
at least two lines of code are collapsible. Code fragments that are under two lines can be 
collapsed by selecting the code. 

To change the minimum number of lines for code folding: 

1. Click Edit > Preferences (on Windows) or Dreamweaver > Preferences (on Mac). 

2. Click Code Format in the Category list and specify the minimum code folding size. 
 

Collapse and Expand Code Fragments 
By default, all the code in Code View is in expanded mode. However, you can collapse code by 
selecting several lines, and collapsing them. You can also collapse code based on the syntax - 
tag blocks or curly brackets.   

Note: The collapsed or expanded states of code blocks are retained across 
Dreamweaver sessions. 
 

Collapse code based on tag blocks or curly brackets: 
1. In Code view, a small triangle appears next to the line numbers corresponding to 

code blocks that are greater than the minimum number of code folding lines 
specified in the Code Folding Size Preferences (see above).  

2. A right pointing triangle            indicates collapsed code.  
A down-pointing triangle           indicates expanded code. 

3. Click the triangle to collapse or expand the code. 
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Note: To expand all the collapsed code in the document, you can use the keyboard 
shortcut Control+Alt+E (Win); Command+Alt+E (Mac). 

Right-pointing triangle indicates collapsed, down-pointing triangle indicates expanded code. 
 

Collapse code based on selection: 
1. In Code View, select the code fragment that you want to collapse. 

2. Click the triangle icon that appears to collapse or expand the selection. 
 

Copy and paste a collapsed code fragment: 

1. Click the collapsed code fragment to select it. 

2. Select Edit > Copy. 

3. Place the cursor at the point where you want to paste the code. 

4. Select Edit > Paste. 
 

Use keyboard shortcuts to collapse and expand code: 
 

Command Windows Macintosh 

Collapse Selection Control+Shift+C Command+Shift+C 

Collapse Outside Selection Control+Alt+C Command+Alt+C 
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Expand Selection Control+Shift+E Command+Shift+E 

Collapse Full Tag Control+Shift+J Command+Shift+J 

Collapse Outside Full Tag Control+Alt+J Command+Alt+J 

Expand All Control+Alt+E Command+Alt+E 
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